How do I force Impress to display font's *actual* color?

When font color is set to ‘automatic’, the text is always white in the editor but black in exported PDF and all the menus/color selectors, no matter the background. I just want to see the actual colors when editing. Every time I export my presentation it turns out all the white (automatic) text is actually black (unless explicitly set to white).
The only fix I found is to change ‘Font color’ from Automatic to white (or any other), in Application Colors, which is not optimal, especially since this also affects Office etc. Help, I can’t put up with this any longer.

I guess you have set “dark mode” in your OS? As LibreOffice follows this since 7.5 (because to many people told they were nearly blind from looking at white background …) we have now to cope with the results.
Would you consider to turn off dark mode in your OS? Just in LibreOffice: LibreOffice Dark Mode: Manual switch to enable/disable coming in 7.5.1 - The Document Foundation Blog

1 Like

Thanks for the reply.
I was expecting turning off dark mode would change the whole UI, but I did it just to make sure, and the UI is still dark (which is good). The icons also went dark but fortunately that’s easy to fix. The white page in Writer does burn the eyes but I don’t use Writer and Impress interchangeably soo looks like my problem is solved…
Although to me it still seems like something that should and could be (relatively) easily fixed. But I guess this is not the place for bug reports/feature requests.

Feature requests
Feature requests should go directly to Bugzilla as Enhancements

Bugs should be submitted directly to Bugzilla.

1 Like