How do I get folders to open with subfolders at the top (like most file managers!) on a Save command?

I have several layers of subfolders in my file structure.

When I open a folder in my File Manager (Linux Dolphin), all the subfolders in that folder are at the top as, I believe, they logically should be.

When I try and save a file in LibreOffice, the folder that is shown has all the contents in alphabetical order irrespective of whether they are files or subfolders. This is intensely annoying!

Can this setting be changed in Options somewhere - I couldn’t find anywhere - or is this a bug that needs fixing?

To answer such a question needs more information. Please edit your question (don’t use a comment at this stage: no one has answered).

Distro name, desktop manager, LO version.

In LO, Tools>Options, LibreOffice>General, is Use LibreOffice dialogs ticked?

I am under Fedora 37 with Plasma KDE desktop, LO The aforementioned checkbox is unticked and the dialogs follow the configuration set in Konqueror/Dolphin.

I no longer need this query. I finally discovered a hidden option in Thunderbird (of all places) where right clicking in the folder for selecting an attachment allowed you to tick Sort Folders before Files which does the trick. Thanks.