How do I get more than one address label per page?

I followed the instructions "File - New - Label " , selected an Avery label with 10 rows and 3 columns. I selected fields from a database and then “New Document”. The new document has one label in the upper left corner of each page and the rest of the page is blank. I tried using the Bibliography database supplied with Libre Office and had the same result. How do I get it to fill in multiple labels on the same page?

Solved – It was a mistake on my part. Before printing the labels it is necessary to Merge multiple labels into one page. I had selected File Print and received the message as shown below with the question “Do you want to print a form letter?”. I had answered NO to the question. The correct answer as indicated below (and in the instructions for labels) is YES which opens the Merge menu. So the labels were printed but not merged to print multiple labels on a page.


What instructions are you referring to? Also what OS and specific LO version are you using?

Sounds as if you have not described all you did. Once you select New Document it will present a screen of labels with just field names in the labels. From there you proceed in a direction to get the data to the labels either Mail Merge or Print. Both get you to record selection.

Also, When setting the database fields, there is a tab for Options. On that tab are selections for Distribute - Entire Page, Single, Synchronize contents. What did you use during creation?

I am using Version: Build ID: 1:6.3.3-0 ubuntu0.19.10.1. I selected Distribute Entire Page and Synchronize contents. When I select New Document I want to print it (print all the labels) It shows a -1 and a page of field codes. If I try Print I just get the page with field codes. If I use the arrow to move to 1, I just see the first address. If I then Print I get one address per page.
I think I found the solution. There is a second print option. I was using File Print just like I do for all documents in Libre Office. But there is a second print option – a symbol with pages and a printer. When you hover over this it says “Print Merged Documents” . I had tried it and it didn’t seem to work because I wanted to print to file. But I tried turning on a printer and printing a test page and this works.


May have seen where your problem is originating.

When you select, Print you should get the following message:

image description

If No is selected I see your results. You should instead select Yes. This will then prompt for the data selection and once selected you should have multiple labels on a page ready for printing.

When this gets to the print process, I can change the printer to Print to File.