How do I get pagedown to show the entire page?

I am using version of Writer and have set the view zoom to entire page. When I start on page 1 I see the entire page and when I press the pagedown key on my keyboard instead of displaying page 2 in its entirety I get the bottom 3rd of page 1 and the top 2 3rds of page 2.

What settings do I use to get my desired behavior?

Actual result:

Expected result:

Update: I have discovered that the Previous and Next Page toolbar buttons on the Navigator do what I want, but not the pageup, pagedown keys on the keyboard. So, based on this information, is there a way to get the pageup/pagedown keys to behave like the Previous and Next page toolbar buttons?

Update: It would seem I may be confused as to the functionality of the View Zoom Entire Page menu option. It seems that this is not a sticky setting. I have observed that pressing the pagedown key and then selecting View / Zoom / Entire Page again, gives me the result I am looking for. Perhaps there is no way to do this all from the pagedown / pageup button. I have included screenshots of the actual result and the desired result.

(Question edited by ajlittoz for inline image display)

The only thing I know of is using CTRL+G and to enter the page you want to go to.

Oddly enough, even this seems to split the page I go to and not display it in its entirety as I would have expected from the View Zoom Entire Page setting.

Had tested on my system before made the comment

I revised my question because I was concerned there might be some confusion as to what I am looking for. It is not only that the cursor goes to the top of the page as it does with your suggestion, but that the entire page is then displayed.

One year later and now using version and I still have not been able to figure this out. Word does this. Select View One Page and each press of the page down/up always shows the entire page, but I have been unable to figure out how to duplicate this functionality in Writer. Using Ctrl+G still moves the cursor to the top of the page but displays only the top half of the page and the bottom half of the previous page.

I came here looking for a solution for exactly the same issue and for the same reasons, so I thought I’d add my support for solving this. Looking over the text pages is difficult without being able to page up or down a full page at a time. It’s even more bothersome in two page view. (I find it easier to render to .pdf and check over the document in a .pdf reader.) There is a closed discussion on this topic from 2020, as well.

The best I found was to add, “To Begin of Previous Page,” and, “To End of Next Page,” to the toolbar then change their icons to < & > respectively. This isn’t perfect, but works well for pages full of text. A half-filled page or page with a single image will get partially page-downed, but going to the previous page works very well.

Tools>Customize>Toolbars>Search>type in a command name from above & select it from the results>Move it to the right panel using the arrows between the panels>Highlight that command>Modify>Change Icon>Ok>Ok

Add/replace keyboard shortcuts to To Previous Page (uno:GoToPrevPage) and To Next Page (uno:GoToNextPage), both in the category Navigate.

1 Like