How do I make password-protected doc default to save with password on save-as?

This past week I had to up-rev from 6.something to

(I had to up-rev because suddenly backspace stopped working correctly, and the answers given were limited to “up-rev” and “turn off track changes”. It broke out of nowhere, in the middle of an editing session, when I hadn’t in any way changed the program!)

OK, the docs I’m editing are password protected. After every session, I routinely save a copy under another name, for another user to view if she wishes.

The problem is that suddenly the default for save-as, FOR A PASSWORD-PROTECTED FILE, is to save with no password. So I have to leave the keyboard, go to the mouse, check the save-with-password box, then go BACK to the filename field, before I can actually save my document. Worse, I have to remember to do this every single time.

Why did this default change? If there is a (new) setting controlling this, I have yet to find it, and believe me I’ve looked.

Updates should NOT gratuitously change the behavior of the program. If the document was password protected, the default for saving should be to leave it that way!

So far this has only come up with Writer. I would assume that it applies to the others, too, but this isn’t something I need to do with Calc.