How do I make the font not automatically change when I type certain characters?

When I type「 or 」, the font changes to NSimSun, even though I’m typing it with the font set to Fairfax HD, which also supports the characters. How do I make this not happen?

In LibreOffice, there is an (old, poor) concept of three groups of scripts (“Western”, “Asian”, “Complex”), which are configured separately; their “support” (= display of controls) is configured by respective checkboxes on OptionsLanguages and LocalesGeneral:

NB: even when you don’t enable these checkbox, the settings that they control still make their effect; just not configurable from the UI.

This concept is the direct reason of what you observe. The Asian “script” has NSimSun font by default:

And whenever LibreOffice decides (using an internal mapping of symbols to language groups), that a given character belongs to Asian group, it uses that font, not the one that you set for Western scripts. This is tdf#148257.

You may set Asian scripts to the same font, which should help in your case. Of course, it requires that you enable the respective “support” (shown on the first screenshot) first.

Generally, @EyalRozenberg is the expert in the wide range of problems riddling LibreOffice in this area. He has very reasonable and creative suggestions for these; unfortunately, they need much effort, and currently there’s no developers who can afford to invest into these.