How do I paste one formula into multiple cells in Calc?

I recently updated from version 5.2.7 to version 6.1.5 (as a result of going to a new Devuan release). One behavior in Calc changed that I’m finding extremely annoying.

Previously, if I had a formula I wanted to copy to a whole bunch of cells, I’d copy (CTRL-C) in the cell with the formula, select the range of cells I wanted to get the formula (with relative references updated), and paste (CTRL-V). It worked fine.

Now, I can only paste to one cell at a time. If I copy a formula from one cell, and then paste to a range, it treats it like a text import; the resulting cells get just numbers, not the formula. I have a similar problem when I try “Paste Special” and select formula.

Again, it works if I copy from one cell and paste to another; the formula copies over as selected. I just can no longer copy one formula to a range of cells, the way i was previously able to with LibreOffice 5.2

Is there a setting somewhere that can restore the previous behavior? This current behavior is driving me nuts.

I just can no longer copy one formula to a range of cells

Never faced that issue and there was no change regarding copying formulas into a range of cells as far as i can remember (relative addresses get udapted and absolute addresses point to the same cell), Did you check while LibreOffice running in Safe Mode (Help -> Restart in Safe Mode)? if this doesn’t appear in Safe Mode most likely your LibreOffice profile is corrupt and you need to reset to factory settings (also via Help -> Restart in Safe Mode).

I would bet it is a clipboard destroyer (aka “manager”) issue similar to many others, like in that question.

Yep, that was it. Thanks. I was running “Clipman” (comes with xfce, I think). When I killed it, LibreOffice Calc started pasting right again.

What’s weird is that I’ve been running Clipman for a long time. With the previous version of Devuan, clipman and LibreOffice had no trouble together. Not sure what changed.

I find the clipboard manager useful, particularly because X has two different clipboards and applications have never agreed which one to use for which. If I can’t resolve it, I’ve previously been able to use emacs to deal with it; emacs understands middle-click vs. paste, and then when you select from emacs it goes into both. (Or, at least, at one point it did.) More cumbersome than a clipboard manager, but at least it works.

Please note for the future:

  1. The answer box is reserved for answers,
  2. For communication use the comments.
  3. To add addional information / clarification please edit your original question.



    This helps keeps the site usable for everyone.

    Thanks.