How do I prevent Writer from hyphenating words that don't fit on one line?

Normally in Writer when a word is too long to fit on the end of a line it gets moved to the next line. Somehow on one of my documents Writer now tries to hyphenate the word instead.

I have checked and it seems to be only this document and only in certain areas that Writer attempts to hyphenate instead of moving to the next line. I have also tried searching the internet for solutions but I could not find any information about it.

How do I stop Writer hyphenating words that don’t fit and make it go back to its regular behaviour?

Go to options → Language Settings → Writing Aids

Go to the bottom pane “Options” and scroll to the bottom. There you can adjust the hyphenating settings.

Hyphenation is a property of the paragraph. It can be set via style or directly at the paragraph. First look into the style of the paragraph which hyphenates. Right-click in paragraph > item “Edit style” > tab “Text flow”. Make sure “Automatically” is unchecked. Then look at the direct formatting of the paragraph. Right-click in paragraph > item “Paragraph”, again check on tab “Text flow”.

In addition it might be a hyphenation which has been set for this special word only. Have you tried to delete the hyphen dash?

How can I prevent automatic hyphenation for one word only at some point, while still keeping the option checked Auto Hyphenation in the paragraph style for that paragraph or for the whole document?

This is not an answer but a new question. Please ask it independently, quoting this one in a link. Then delete your “answer”.

I have the solution but would give it only after you’ve cleaned up this question.