How do I start LibreOffice Appimage (in Archlinux) with a different VCL (kf5 instead of gtk3)?


I use LibreOffice as LibreOffice-7.3.standard-x86_64.AppImage.
The operating system is Archlinux, more precisely CachyOS with KDE.

Why this old LO version of all things?
Because there is a bug in newer versions with poor, tattered font rendering, when anti-aliasing is deactivated (mainly refers to LO Writer).
See for example here:

So, now to the current problem:
Until recently, the above-mentioned Appimage version as VCL still used kf5.

But a few days ago there were some major system updates, including an upgrade to Plasma 6 (maybe it has something to do with that).

Now LO (in the above-mentioned Appimage version) suddenly uses gtk3.
But this is not so good in terms of presentation. This can be seen in detail, for example, in the fact, that these small graphics are missing in the drop-down menus next to the text. But these little graphics in particular have always helped me find what I want faster and more clearly.

For comparison, if I download and start the current Appimage version, it starts with kf5.

That means, it can still work with kf5!

Unfortunately, I can’t find any place where I can change the default setting as to which environment variable is used.

For the version installed via the repos, there is a file, e.g. in the /etc/profile.d folder path

This file says:

# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gtk3_kde5
#export SAL_USE_VCLPLUGIN=gtk3

This is how you would set it, for example, if you wanted to select kf5.

But the Appimage version apparently doesn’t use this file, even though it also uses the same profile under /home/user/.config/libreoffice/4 as the installed version from the repos.
I have already manually stored several versions of this file there with different names:

All files always have the same content, as shown above. But it didn’t help.

Does anyone have an idea how I could still get the appimage version to use kf5 instead of gtk3 again?

PS: Sorry, my English isn’t particularly good! Therefore, most of my English articles were created with the help of online translators. I apologize if these contain errors.

I have the same issue, but want the repo version to use specified vcl.

Currently, LO starts with VCL:kf6 on Plasma 6 which is bugged and doesn’t scale properly. With qt5 it all works as before, but I can’t make LO use it globally.

My assumption is that we can change it in:

Options->Advanced->Open expert configuration

However, I can’t see which of the setting will change the whole VCL to use kf5 or qt5.

Wild guessing from LibreOffice as AppImage | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft
maybe dig in
Home - loaih - LibreItalia Gitea: Git with a cup of tea