How do I stop it from printing in landscape mode instead of portrait mode?

I found this solution PRINTER PROPERTIES, JOB OPTIONS, COMMON OPTIONS, Highlight ‘Scale To Fit’, Change ‘Pages Per Side’ to 1, APPLY

MANY MANY PEOPLE have been troubled by this longstanding LibreOffice bug … including my spouse at 2:00 am.

Here is yet another workaround, which I found by exhaustive testing.

The chief advantage of this workaround is that it requires NO changes to the document itself.

• MacOS: works for both 10.11.6 (El Capitan) and 10.12.6 (Sierra)

• LibreOffice: works for both 5.3.6 and 5.4.2

  1. Call up the print dialog for a “Letter” text document by the usual method, namely “File” → “Print”

  2. If necessary, select the menu item “LibreOffice” (other choices in this menu include “Layout”, etc.)

  3. Two tabs will be visible now: namely “LibreOffice Writer” and “More”; select the tab “More”

  4. Now a menu will be visible, whose choices include “All Pages”.

  5. (Here’s the “magic”) select ANY menu item OTHER than “All Pages” … then reselect “All Pages”.

The net effect SHOULD be nil … but instead, this sequence will trigger a refresh of the entire dialog box … and the refreshed box will display a now-correct “Portrait” mode.

Problem solved … but alas, this fix must be applied anew for each print step.

Thank you for sharing this finding; I’ve mentioned it on the issue page, so it may help Mac developer to find the problem.

Please have a look on the amendments to my previous answer.

Thank you for this workaround. Although it must be done for each print step, it does assume that the bug is in LibreOffice and, importantly, that the bug will soon be fixed. I appreciate Lupp’s workaround but it presents the risk of having to reset templates back to their original, letter-size dimensions after a bug-fix for this issue drops into LibreOffice.

Thanks, Mike Kaganski, for a pointer to the bug report.

Having recently gotten the message from Microsoft that my old Office for Mac 2011 will no longer be supported, and finding that Office 2016 is bloated beyond all comprehension, I discovered LIbreOffice as a welcome alternative and ran into this bug. Thankfully, I found your workaround quite helpful, though not a preferred remedy. I am hoping that the developers will pay attention and can finally fix this problem.



@orestk: This will depend on the frequency of your prints and the number of templates you are using.
Bug tdf#92190 (61 comments to date) was reported 2015-06-19 and is not yet assigned. May be long-lived.

The magic button is Brochure. Turn it on, perform #5 above, then turn Brochure off. That’s the magic.

There is no magic. There are a few workarounds, and to know one of them should not prohibit the study of the others already suggested. Depending on specific requirements different users may decide to prefer different ways.
This thread is rather bloated now. A bit more concise is this one on the same topic.

I too have this same problem with OSX 10.13 running Libre Office version printing to 8.5 x 11 inch paper. Playing with the above mentioned “Brochure” check box under → Print → More fixes it for me too.
Yes it comes back every time you try to print.

@miekb: This was already reported often. Did you also try the “Tiny-Change-of-Size-Workaround”?
Reports on this workaround, in specific concerning the changes for templates would be actually valuable for other visitors of this thread.

Tried and tried - but it didn’t work. I will work my way through the entire chain trying everything else but I do say that this has been very frustrating :frowning:

Strange… And:
Can you confirm that the issue is still present in LibO version 5.4.4 (or higher)?

Thanks for this work around. What a frustrating bug!!
I’m running Version: which claims to be up to date. OS X El Capitan 10.11.4

5.3.7 is supposed to be a reasonably enhanced, and at the same time well debugged “still” version. Nonetheless V5.4.4 also is no longer “fresh”, and on 2018-02-04 the first release of the 6.x.y series ( was published. I still hope to get told and confirmed the state of the Mac/Letter/Landscape issue for the fresh versions. I cannot test myself.

If the page orientation under ‘Format’ > ‘Page’ is set correctly for each used page style, the issue should surely lie in the range of printer/printer driver. There are many different Epson printers and probably outdated printer drivers. To get help more likely, you should name your OS/version, the printer, and the actually used driver.
On any system the same printer (hardware) can be installed with different drivers (software) under more than one names. One of the installations may be set as Standard … Anotherone may be chosen for printing from LibO…
A lot of fringes…

Edited regarding the course of the discussion here: Irrelevant parts striked out, explanation below added.

As I see it, it turned out that the issue is completely due to the operating system being OSX of some verion((s) on a Mac. In addition it seems most likely that it specifically is related to the outdated USA paper sizes. Unfortunately the OQ didn’t name the OS even after being requested expressly.

In this thread and in others on the issue as well, the preferred suggested workaround was: Omit the usage of the predefined paper size and replace it by a slightly different ‘User’ defined size, say about 2/100 of an inch (2.54 cm) or 0.03 cm larger in one dimension. The change must be sufficient to persist over a save/reload cicle. (During my testing 0.02 cm e.g. were first accepted as a relevant change, but not properly saved then.) Please test to be sure.

Regarding the recent answer by @JohnSidles:

As he stated himself, the steps need to be repeated in advance of each printout.
This may be error-prone and time-consuming.

I would prefer to apply the workaround described above to each template I have in use, in specific to the standard template of any document type if afflicted.

(Sorry, lacking a Mac I cannot test myself. But I watched the related threads, and feel rather sure that my advice is not just a blind man’s talking about colors.)

It’s not unique to MacOS or to letter size paper. I have the same problem with 9"x12" paper and Ubuntu 16.04. None of the work-arounds discussed in this thread make any difference. It will always print in landscape, even though the printer only supports portrait orientation.
Version info
Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default;
Locale: en-US (en_US.UTF-8); Calc: group

If the problem is due to the OS why does Office and every other application print OK?


Check also FilePrintOptions tab▸Use only paper size from printer preferences (ticked or unticked)


Thanks but I have tried that. :frowning: