Landscape vs Portrait printing to Letter paper - size on Mac OSX?

Although Portrait format is selected, documents printed to a “letter” size sheet via MacOS Sierra 10.12.6 print in landscape format. Have to select A4 size on each occasion to get the document printed in portrait.

There are described two workarounds in this thread e.g, one presented by @JohnSidles, one by myself. .

I just upgraded Libre Office and this started. Beyond annoying to have to do workaround for every document. I was not able to report as a bug either.

UPDATE 2018-12-20 by Mike Kaganski (for final resolution, since it still keeps getting attention):
The problem was solved in LO version 5.4.4 onward (see tdf#92190). If you suffer from this, and have an older LibreOffice version, please update. If you have a similar issue, and have the mentioned version or higher, please file a separate bug in the bug tracker.

=== Original text follows ===

(This is not a new answer, but a compilation of answers to similar requests.
I hope this gives easier access to the workarounds again. )

The issue seems to only occur when using the operating system OSX of some version on a Mac. In addition it seems most likely that it specifically is related to the outdated USA paper sizes. Probably not all versions of LibO are afflicted.

@jmills59 Sidles recently posted the following workaround. Cheers!
First workaround:

Call up the print dialog for a ‘Letter’ text document by the usual method, namely ‘File’ > ‘Print’
If necessary, select the menu item ‘LibreOffice’ (other choices in this menu include ‘Layout’, etc.)
Two tabs will be visible now: namely ‘LibreOffice Writer’ and ‘More’; select the tab ‘More’
Now a menu will be visible, whose choices include ‘All Pages’.
Here’s the “magic”: Select an option different from ‘All Pages’, then reselect ‘All Pages’.

The net effect SHOULD be nil. But instead, this sequence will trigger a refresh of the entire dialog box, and the refreshed box will display a now-correct ‘Portrait’ mode.
A few similar workarounds were also reported to be successful.

The chief advantage of this workaround is that it requires NO changes to the document itself.
• MacOS: works for both 10.11.6 (El Capitan) and 10.12.6 (Sierra)
• LibreOffice: works for both 5.3.6 and 5.4.2

Second workaround (suggested more than once and reported to actually work):

Omit the usage of the predefined paper size.
Change to a slightly different ‘User’ defined size, 2/100 of an inch larger smaller in one dimension, e.g.
The change must be sufficient to persist over a save/reload cycle.
(During my testing 0.02 cm e.g. were first accepted as a relevant change, but not properly saved .
0.03 cm were correctly saved then.)
To preserve the wrapping you may compensate for the paper size changing a margin by the same amount.
Please test to be sure.

This second workaround, I remembered, solved decades ago some similar printing issues for me.

There are also advantages:
• If your documents are based on templates, and never got changed their paper size in advance, you only need to change the templates as described above, and to answer 'ok’ when you are prompted for a document if you want to apply the changes.
• Once the bug is fixed you change the templates back. Done!

(Sorry! Lacking a Mac I cannot test myself the complete proceeding.)

Ridiculous to have to use a work-around for every document. This just started when I upgraded Libre Office.

I won’t comment on your words - and no contributor here is Mr. Documentfoundation.
However: Did you read my suggestion stressing the usage of templates? Did you understand it or do you want additional explanations? It’s a way to avoid the need of action on every single print job.
Did you consider to use internationally standardized paper sizes as about 95% of mankind did?

Millions of Americans use a standardized 8.5’‘x11’’ “Letter” size sheet. It is ludicrous to assert that the problem is not with the software, but rather the paper being used. How can you expect people to adopt software that contains a ridiculous bug like this that impacts users of Sierra? Furthermore, they come here to get help and end up being shamed by some anonymous troll for not using the same sized paper as Europe. It’s totally unacceptable on every level.

Quoting @Packer_guy79: “It is ludicrous to assert that the problem is not with the software, but rather the paper being used.”
Who did that? However, it is simply a fact that the problem never was reported for paper sizes different from ‘Letter’.
The issue was discussed as bug tdf#92190 and seems to be fixed in version LibO 6.0 to come soon.

I had the problem on A4 in Europe. All my own selfmade printer presets printed to landscape, even as pdf, but not the factory defaults. I remade my own presets from the factory defaults and overwrote the old ones. Cost me 30 mins to find out. And I still don’t have a Portrait/Landscape choice. Apparently it prints a landscape doc in portrait but rotated 90 deg. so it turns out alright. Odd behavior.

As far as I can see, this is the first report of a similar issue and probably related to the one often reported concerning OSX Sierra with paper size ‘Letter’ by default. I don’t feel sure therefore, if it’s actually the “same thing”.
OS? OS version? OS locale? LibO version, locale, language setting? Was A4 chosen by you or was it set as default?
@MIke Kaganski: You announced a fix for LibO 5.4.4, 6.0 elsewhere. Is this still valid? Do you think what @Dutch reported is actually related?

Yes it is still valid; the issue by @Dutch needs further investigation - all the questions you mentioned at least. I didn’t see the sameness there: that “but not the factory defaults”; that “I still don’t have a Portrait/Landscape choice” (those having the Letter issue had the choice; only it worked incorrectly)…

Third workaround:

Open “Print” dialogue. Select “More” at the top of the lower right box. Check “Brochure.” Uncheck “Brochure.”

That should switch everything back to portrait.

An interesting variant to the “supposed-nil-net-effect” trick suggested by @JohnSidles .

This one worked for me as long as I also changed the “All Pages” setting to something else and then back again.

Rather sad that such a significant bug persists for so long.

Just data point. I ran into this again, today – 19 December 2018.
macOS Mojave – Version 10.14.2
The workaround I used was;
Format-> Page .
Change the paper width to 8.51

Question: Is this now the contender for the longest lasting bug that directly impacts general users?

Which LO version?

Oops – Sorry


As was mentioned above: the fix was released in 5.4.4.