How do I switch off automatic superscript in an expression like "21st"?

When using Writer, I want my dates to appear as “2nd”, “6th”, “23rd” etc., WITHOUT defaulting to superscript. How do I switch off the superscript?

I modified the title of this question and also text of question, because it was little bit insulting… Please be patient this is volunteer forum not a paid one. You may not get an answer immediately or at all… If you need such a help then I suggest to make a contract with one of the companies that offer such a support, see LibreOffice partners:

Not having seen the original, I can’t judge this specific case, but it remains true that if the programmers and designers of Libre Office had not unwisely set this option, those of us who provide support here and in other forums wouldn’t get the insulting comments. See my articles about superscripted ordinals in TUGboat and elsewhere over many years.

You go to Tools → Auto Correct Options. Select Appropriate language at the top (for example English - USA, although default language will be already selected). Then, from the tab Localized options disable Format Ordinal Number Suffixes.

This should solve your problem.

This setting in Localized Options is valid for all languages.