How do I turn off autotext?

Even though I already turned off autocomplete and autocorrect completely, LO makes suggestions for a few words and will then replaces them if I press return right afterwards. For instance, ACK then return gets replaced by Acknowledgement. You then return gets replaced by Yours Truly. The replacements only happen after I press return. I don’t want any of these replacements. They completely break the flow of my writing process. I’ve even cleared out the autocomplete and autocorrect table by deleting all the entries on top of turning off autocomplete and autocorrect completely.

After a lot of searching, I found my problem is probably connected to the AutoText feature, which is listed under Editing (right below the Find & Replace option). The suggestions and replacement LO inflicts on me are in the Standard category.

But despite what the help pages say about the AutoText option and deleting entires, the help page is wrong. None of the default entries can be deleted the way it says. I’ve found no way to delete the default AutoText settings so nothing is replaced. I’ve found no way to turn off AutoText completely either. (Turning it off complete is preferred)

I’ve tried googling for further help but it all the results led me to autocorrect/autocompletion stuff I’ve already tried. A couple AutoText links didn’t help either other than reveal that my problem is probably with the AutoText feature. I’m at the end of my rope on this problem.

Since autocorrect and autocomplete can be turned off completely, I’m hoping there’s is a way to turn AutoText off completely.

I’m using LO 5.0 if that makes a difference.

Hi, thanks for your quick reply. I tried going to the AutoText dialog then to the Categories there.

However, the only Category I was allowed to delete was “My Auto Text”. When I selected any other Category (“Business Cards, Work”, “Only for Templates”, and “Standard”) the delete button was disabled (dark gray and clicking didn’t nothing.)

When i tried to delete anything inside the Categories, I encountered the same problem, meaning for the categories “Business Cards, Work”, “Only for Templates”, and “Standard” i could not delete the entries. I could not even edit the entries (editting the entries so that the replaced text matched the originally typed text would work similar to deleting the entry.)

I tried checked LO 5.0 and the most recent release of LO In the recent release the AutoText in the menu system was moved to tools, but I still couldn not find any option to disable AutoText nor was I able to delete or edit the offending Categories.

It’s starting to sound like I should file a bug report. I’m going to go try filing a bug report and see what they say. Maybe it was an accidental oversight.

Yes, same behavior here. I didn’t pursue it that far.

Since it is impossible to delete the default AutoText entries one by one or in bulk and it is impossible to remove the file paths, I had to destroy them with fire!

Go to *c:\Program Files\LibreOffice\share\autotext* and rename the folder en-US. Or rename the folder with the language code that you use and don’t like.

The next time you open the AutoText options the program will complain “Can’t find the file path” or something, but the unnecessary AutoText entries will be removed and the complaint will pop up only once.

Enjoy your new freedom where you are the master of AutoText!

I’m on LO 5.1. I don’t see a way to turn off autotext (which seems weird), but if you invoke its dialog (F2 or via the Tools menu), you can delete what you want piecemeal, or select Categories there and delete by category, which will be easier.

In the Autotext Box is on top a checkbox “Display remainder…”. If I check it it shows me the name of the entry after 3 characters, hitting Enter insert it.

Unchecking the box does not do anything. I think that is the shut off.

1 Like

In LO Writer, go to Tools → Auto Correct → Auto Correct Options, Word Completion Tab and uncheck “Enable word completion”.

Also, at Tools → Auto Correct, uncheck “While typing”…

Hope that helps…