How do I turn off spelling suggestions as I type?

I’ve been using Libre Office for about a week, and today when I started to work on a text document, a little box with spelling suggestions started popping up right above where I’m typing, which is incredibly annoying. (And also weird that it took a week for it to start happening.) After looking on this forum, I made a couple of changes under the Tool menu - turned off Automatic Spell Check, as well as Auto-Correct While Typing. When I made these changes I stopped getting the suggestions for about ten minutes, but then they came back. I made sure that both settings were still turned off (they were), and quit and reopened the app, but that didn’t help. After scouring the menus for any other weird settings, I don’t know what else to try. Seems like there’s some sort of bug. Any suggestions are much appreciated.

You probably ran into Word Completion, a feature that suggests words with lengths over, usually, ten characters, which is why you may not run into it that often. You turn it off on the Word Completion tab of the AutoCorrect Options dialog box.

To show the community that your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers.

Thank you, that was the issue. Also realized that if I type fast enough the word completion isn’t always noticeable. :blush: