How do you edit an inserted field?

When I insert a field it seems to come with an unwanted grey background. I cannot see how to change this. Please, can someone tell me how to do it.

Answered in comment below.

I found the answer! ctrl F8 or go to the sidebar and click on the field shadings icon.

I wouldn’t recommend removing the gray shading. It is a reminder that something is being inserted/managed by Writer and you can’t partially edit it (you can only replace it entirely or erase it). The shading doesn’t print, so it is harmless. If you don’t like gray, you can change the colour with Tools>Options, LibreOffice>Application Color.

No that it’s not the answer, there is the Menu/View/Field Shadings and Field Names, where you can change how they are saw.