How do you set the default font in LibreOffice Calc (v6.2)

I am unable to set the default font in LibreOffice Calc (v6.2).
However, I am able to do so in LibreOffice Writer (v6.2).

Hello,

perform the following:

  • Open a new Calc spreadsheet
  • Go to Styles -> Manage Styles (or F11)
  • Click icon Cell Styles (leftmost icon below Styles*)
  • Right click on Default → Modify -> Tab: Font
  • Set your preferred font + options
  • Click OK
  • Menu File -> Templates -> Save as Template
  • Provide a Template Name (e.g. MyCalcTemplate)
  • Select a Template Category (e.g. My Templates)
  • Important Check option [x] Set as default template
  • Click Save
  • Close your document (no further save required) and open a new Calc spreadsheet
  • Check your new settings

Hope that helps.

If the answer helped to solve your problem, please click the check mark (:heavy_check_mark:) next to the answer.

Problem solved.
Please add this answer to the LibreOffice Help.

Hello there, I’m using LibreOffice 7.1.0.3 (x64), and the “File → Templates” Menu is no longer present (or maybe I cannot find it…). How do I save a default style for my sheets? Thanks

The File -> Templates menu is still there, however all menu specifications in answers are related to “User Interface” set to Standard. If you are using any of the Notebook-Bar settings (Tabbed, Tabbed Compact, etc…) the location will be different. Hence you’d need to tell which UI interface setting you are using (e.g. in Tabbed UI it is in Tab File and Icon Save as Template).

Hi opaque, thanks for the answer. I’m using LO as it comes, default installation and so on. The user interface is set to Standard. No “File → Templates” menu, though.

I found out that the correct path is not “File → Templates” but you need to click on the down arrow near the Save Icon, and then select “Save as Template” (shortcut Shift +F11). Worked for me

image description

Whatever is wrong with your version - on my Windows system using

Version: 7.1.2.2 (x64) / LibreOffice Community 
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 1; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DE); UI: en-US, Calc: threaded

I still see:

image description

Go to ```
Tools → Options… → LibreOffice → Advanced → Expert Configuration

and search for "org.openoffice.VCL:LocalizedDefaultFonts['??']" where ?? is your locale.

I've added "Segoe UI" to my locale:

org.openoffice.VCL:LocalizedDefaultFonts['en']   LATIN_SPREADSHEET

and it's there. No need for templates...
1 Like

And then you start LibreOffice in a different locale/language or reset your profile and suddenly you are missing your default font.

So you do the same for each locale you use…