How do you start a nested list on the same line as the parent list item?

Thanks for offer. On re-opening my test file the lines were even so I set Dummy character style to not hidden, then back to hidden and the uneveness came back. File attached which will be evenly spaced
NestedListSameLine2.odt (11.5 KB)

This is what I get on changing style and then back until I close and re-open.


Very strange: your file is OK here. I then followed your stance with Dummy character style and document still OK when style reverted to Hidden.
Could it be a subtle difference between Windows and Linux versions? (You are under W, aren’t you?)
EDIT: forgot to mention I zero-out the vertical spacing to better see any uneveness. There is none, but is 0 spacing special? Could you check on your side?

I had set 0.10 below paragraph spacing for some reason; if I set it to 0 it seems OK.
If I set it back 0.10 the unevenness recurs.
Clicking Print Preview clears the unevenness.
I might change to latest version as my test version. First I see there is a Windows update I can download.

Version: (X86_64) / LibreOffice Community
Build ID: 9f56dff12ba03b9acd7730a5a481eea045e468f3
CPU threads: 8; OS: Windows 10.0 Build 22621; UI render: Skia/Raster; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: CL threaded

After Windows update and restart, still same. Installed parallel still the same. I tested on another Windows 11 computer (LO and same thing so your guess that it is a Windows thing is probably correct.
Toggling Formatting Marks solves the problem.

It might be useful to file a bug report to have the opinion of developers.

Done, tdf#156123

Note that since v.7.2 (tdf#64222, commit 5ba30f588d6e41a13d68b1461345fca7a7ca61ac), Writer supports special formatting of “paragraph mark”, to be interoperable with Word. This means, among other things, that paragraph make may be hidden - basically, making a series of paragraphs to not break lines. And that allows to create the wanted effect.

Since 7.5 (tdf#155238), the way how this is stored in ODF has changed, to use a special attribute.

But all this still has no UI in Writer, so only possible by directly editing ODF.

@mikekaganski Could you explain how to set this special formating? I’d like to experiment as this could be a solution to the “inline heading” recurrent question.

@ajlittoz sw/qa/extras/odfexport/data/ParagraphMarkerMarkup.fodt - core - Gitiles is an example of a FODT with such a markup (since v.5.4). The loext:marker-style-name attribute of a paragraph points to an autostyle (i.e., DF), and that autostyle is just a normal autostyle, pointing to a proper style (or a default if missing), and adding more.

@mikekaganski If I read correctly th ODF (I am no expert), the mark should turn red. With, it remains blue. However, its size is smaller than the others on the Text Body lines I added.

This is no problem, since this reference can be made to point to a named character style so that this style can be manipulated in the GUI as usual. A “template paragraph” could be stored as initial contents in a template or as an AutoText entry so that it can be reused without the need to go tweaking the ODF.

Heh, I see I made a thinko (I forgot to type “7.” when I wrote “since v.5.4” - I intended to write “since 7.5.4”).

OK, thanks. I’ll keep an eye on the feature.

There’s no such option.

That’s ridiculous.

Thank you for your response encouraging to continue answering questions and trying to help.

What? [filler text so this comment is long enough to post]

@lomacar, I think you irony detector is out of order. Try to fix it. And in case you still do not understand it, your “that’s ridiculous” comment was a ridiculous comment: this is a user to user site, if you want a new feature, ask for it. But please, be polite.

Really so. No one is bound by any contract to answer. Even when he has candidly and clearly stated that there is no such option, it is a valuable piece of information. I need to thank him than ridiculing. I agree with RGB-es.

Wow. Why would anybody think I was ridiculing them when I say “that’s ridiculous”, I didn’t say “you’re ridiculous”. It is ridiculous that LO would not be able to do such a commonly needed thing. I guess I should have said “That’s ridiculous. Thanks for you answer.” I would have expected a reply of “Yeah, I know, sorry.” Not for somebody to take it personally.

1 Like

P sure the OP was already blessed with the knowledge of “there’s no such option”. That’s kind of the entire foundation for creating a new topic in the first place. Simply repeating that and offering nothing of substance is not valuable at all, a waste of time and resources, rude, and so on. :grin:

Indeed. Especially in response to a five year old topic.