How does one toggle between lining figures and old-style figures with supported fonts?

Hi LibreOffice community.

I am having trouble in getting LebreOffice, in Windows 7 on a 64 bit laptop computer, to render numerals as “lining figures” rather than “text figures” (old style figures, ranging figures, etc.). I am using a font (ET Bembo installed as ET Book but the system still calls by the related ET Bembo) that has both forms in separate font files. Earlier this year (2020), the numerals in the same document were rendered as lining figures but now, with this newer version of LibreOffice, it is not so. Please offer help on restoring to lining figures for numerals.

I have tried to explore around LibreOffice in areas that seem to me to have something relevant to this issue. The only thing I have found is the Character window accessed under the “Format” drop-down menu. To the right of the box to select a font is box to select Style, wherein I select “RomanLF” for Roman with Lining Figures for numerals–RomanOSF doesn’t show as an option even though that font is installed on this computer. So far this avails apparently nothing in rendering numerals as lining figures rather than non-lining figures.

So far, in my initial internet search, I find that LibreOffice uses a “layout engine”. I don’t know the name of this engine but I understand there may be means of managing typography features in this layout engine for display and print rendering. I also understand that LibreOffice implements something called “HarfBuzz” that also has means of managing typography features, perhaps with “typographical markups”, for display and print rendering. I have yet to find anything identifying how to properly engage in managing features in either system.

Thank you for the help that can be offered through this LibreOffice community.

Kind regards,

Is the font in question an OpenType font? If it is:

  1. Open the character window.
  2. On the Font tab / under Western text font, click Features.
  3. Find Old style figures, or onum, or something similar (if in doubt, show a screenshot of the dialog) and tick/untick as necessary.

Note that you can try to do it directly from the font selector on the formatting toolbar, simply click inside and add :onum after the font name so that it be ET Book:onum (or ET Bembo:onum, or whatever).

If, however, the font is not OpenType or does not support the above feature, you’ll have to find another one.

Unfortunately, the font I am trying to use is not OpenType. It is TrueType. When I originally discovered the font and sought to install it on my computer, I did some–perhaps not exhaustive–searching for an open (free) and safe version of the Bembo (Book) font in OpenType format. Thus far I haven’t found such.

What is puzzling to me is the TrueType font I have installed is in 5 separate files with the following descriptions:


This would lead me to believe that I should be able to choose the relevant font for old-style figures or line figures. Shouldn’t there be a way to force LibreOffice to use the one of my choice? In the Charactor window, there are several options under Style. One of these that I have selected is RomanLF. So far, this hasn’t given me line figures for numerals.

This leads me to consider there may be something I can adjust at the layout engine (which I have learned my be “Skia”) level or the text shaping (HarfBuzz) level.

Do not answer your own question unless it is a real answer. Modify the original question or use the comment option.