How does the "Save" icon work?

I just got a new computer (Ubuntu 16.04) and, therefore, a new version ( of LibreOffice. I am puzzled by the “Save” icon. When I’m working on a document and wanting to save as I go along, so as not to lose content if there’s a system crash or freeze (fortunately, seldom happens), I am used to just clicking on the Save icon.

But now when I click on that icon, I’m given the choice of either “Save As” or “Save Remote Filet.” And, according to my tests, clicking on that icon does NOT save my document, because when I go to close it, I get a dialogue telling me: “Save changes to document “testing.odt” before closing?” and “Your changes will be lost if you don’t save them.”

I don’t want either the “Save As” or the “Save Remote File” option. I just want to save the document on my computer that I’m working on. I know I can do a keyboard shortcut of " Ctrl+S" but I’d rather use the icon, which I just do without thinking and have done for many years.

What am I missing here? Am I not using this icon correctly? Or is there some other icon I should be using? Is there a simple save icon that I can add to the toolbar via customization? When I try to customize the standard toolbar, it has the word “Save” checked while the “Save As” is not checked. However, I seem to be getting that icon that just does a “Save As” or a “Save Remote Document.” Any help appreciated.

Have you tried left double clicking the icon?.. Works with me with Linux-Mint and LibO 5.2

I did try double clicking the icon and that DOES seem to work. Thanks! It would be nice if I could tell from the icon whether the document needed saving. All in all, I’m not terribly happy with how this Save icon is working. But at least the double-clicking will save the document, so that is a big step forward.

I just reverted to, Windows 8.1. Save item seems to work correctly, I only see the “Save As” and “Save Remote File” options if I click the down arrow for the drop down menu.

Check in Tools, Customise, Toolbar, Standard, and make sure the correct Save icon is enabled.

The Save icon does not work properly for me. I tried it again, making sure to click on the floppy disk icon and not the down arrow for the drop-down menu. I get the same result for both the floppy icon and for the down arrow, namely the “Save As” and the “Save Remote File.” So that icon does not seem to be working properly.

The save button (single left click) has worked correctly for me is v5.1.3, v5.1.4 and v5.2 using both Linux Mint 17.3 and xubuntu 16.04

Please note that I get my versions directly from LO not the distro versions. Have had/seen too many problems with their releases - like having to add Base separately and Writer table problems in Open Suse version and a few others.


Under Windows 10 64 bits pro, I get the same error with the new version : the save icon stays on after I save.

I didn’t have to check if I use the right icon - because it’s not a new computer, it’s only a new installation, an update - but I did check and of course, nothing had been changed in the toolbar customisation.

I hope it’s a bug, not a feature, and someone will be able to correct it soon: i think clicking twice, even thrice or more is not a solution.

Thanks in advance.

(Old versions are not easy to find. Anyway, I managed to download a 5.0.6, waiting for the correction…)

Another thing that works is clicking the left margin of the save icon. Clicking in the middle gives a Save as/Save Remote response, the same as the drop down click. The mapping of this icon leads to confusion.