How I can delete empty line after table in Writer?

"Ctrl+Shift+Del" still works for me with version 3.5.7, but not any longer with version 3.6.3.

See also → Bug 45784 - Removing empty lines after a table

Don’t working in too. Also I see that is not stable functionality. That’s bad.

you have to have the cursor on the end of content in the last cell of the table… not on the extra line as one would think. worked for me.

What is the right shortcut for a Mac with a standard keyboard (i.e. no numeric keypad)?

Works perfectly, for me. Ubuntu 14.04.2 LTS, Keyboard QWERTY set as English International with alternate keys. Cursor at the end of content last row.

works for me with LO on Ubuntu 17.04

Excellent!! ⌘+⇧+Fn+Del on Mac keyboards (LO 5.3.6).

Bug 45784 - Removing empty lines after a table

has been marked as a duplicate of

Bug 60967 - EDITING: Table shortcut Ctrl+Shift+Del ineffective cannot delete following paragraph of a table.

EDIT 2013-05-18/2014-08-29



target: 4.3.0 · 4.2.5 · 4.1.0 · 4.0.4 · 3.6.7

Comment #33 by Michael Stahl 2014-05-02:

"fixed the empty-paragraph case from
comment #26.

for the paragraph at end of document
case (comment #24 and #30) i’ve done a
bit of testing and found that there
are quite a few things that break if
the document does not end with a

  • Load Styles crashes
  • Insert->Footnote then Insert->Index (in the table cell) crashes
  • Select All has numerous problems (and probably requires a special handling similar to table-at-start-of-document, cf. bug
    37606), Select All then Delete will
    crash too
  • ODF export works but ODF import adds a trailing paragraph
  • Word is apparently unable to end the document with a table, so there’s an
    interop issue
  • save as DOC, reopen with LO the table is gone

so i am resolving this bug as FIXED,
please file a new bug for the case at
document end."

There is an answer in the French FAQ:

The idea is to convert the table in text with tabulations → remove the last paragraph → convert the text in table.

To convert table <-> text: menu Table > Convert.

A smart workaround …

It’s work, but not useful. Dear developers, could you create normal function or just add ability delete empty line?

@VitaliyAT: Please contribute to fdo#45784.

I confirm this method does work. It is all I needed. I made a table and it produced an empty page. I put the pointer in the last cell of the table, I chose Tables > Transform (could be different, mine is in Russian) > Table to text and vice versa. I transformed the table into text, then deleted the invisible character (Ctrl + F10). When I made it a table again,. there was only one page, not 2. Use this wisdom. - not resolved, pity

I just tried all listed remedies in nothing worked.

Also added a comment to the bug report

Workaround I just used: make the font of the last line, which cannot be deleted as small as possible then the error doesn’t appear so obviously.

v4.0.3.3 portable on XP/SP3 not solved

However comment 12 in bug fdo#60967 indicates that in the next build (after 2013-05-17 22:22:22 UTC ) there is a solution implemented.

Here is an unfriendly workaround which may require understanding the simple XML syntax. Open the document with an archive manager and edit the inbound file content.xml. Find the end of your table and delete the subsequent sequence which takes the form <text:p text:style-name="P5"> ... </text:p>.

Be careful for working within the editor with the about of the edit may revert the changes.