How long a formula can Libre Office Calc use?

I have a Calc Workbook with many entries. When I edited the Formulae in a certain column to compute on about 95 values everything seemed to work that day but when I tried to re-open the file to that page the next day Windows shut down LibreOffice with the message. LibreOffice has stopped working correctly. Windows will close the program… The File can be recovered but if I attempt to save it the same thing happens. The computer is running Windows 7. I then upgraded LibreOffice from to but the same thing happens. I went back to an earlier copy and updated it. All seemed well but the next day the same problem. I copied the problem file to a USB stick and can use it with no problems in my Dell Precision M6400 laptop computer which I recently upgraded to Windows 10 but left Libre Office on it. Both computers are running 64-bit versions of Windows.
So it appears that LibreOffice 5 cannot process a file that LibreOffice 4 has no problems with.
Any suggestions?

Please try resetting the user profile, sometimes solves strange issues.
Usually it’s enough renaming/deleting the file “user/registrymodifications.xcu”, it affects all the options in Menu/Tools/Options, and the files “user/basic/dialog.xlc” and “scrip.xlc” are overwritten, additionally custom colors in “user/config/standard.soc” are lost.

Inserted the word Deleted into the middle of the registrymodifications file and changed the extension to Ducx. Had to tell LO where to find the file so I guess the renaming did reset things but when I attempted to open a specimen file which contains only the page with the long formulae and another which is linked to it I get the same result as before. (I used LO 4 on the other computer to delete the other pages and save the shorter file. Still 611KB.)

What file format do you use to save?

This file was created and always saved in ods format. And only LibreOffice of various versions has looked at it. Thanks for trying to help.

Please report the bug.

Resolved for me by the following suggestion.
Please try first with ‘Tools → Options… → LibreOffice → OpenCL → Allow use of OpenCL’ unchecked