How reject autocomplete suggestion

Autocomplete can be useful, so I don’t want to turn off, but how do I reject a suggestion?
So for example if another cell contains “a b” and I want to type in just “a” then 2 options are:

  1. “a” followed by 2 spaces followed by return, but this adds 2 spaces to end of “a” that I don’t
  2. “a” following by any character, then delete character and then press return

These both involve pressing 3 keys after what I typed, rather than the normal single “return” key - also tried pressing enter at same time as pressing Shift or Ctrl, or Alt and these don’t work, but this is what I am looking for - a single key or key combination I can press which accepts what I have actually typed and not the autocomplete suggestion.
Or can I change autocomplete so that “return” does NOT select suggestion and I have to press some other key (like F2) to select suggestion, so that pressing “return” always enters into the cell what I have actually typed, but autocomplete is still on.

Have you tried Ctrl+Z once you have the string you want?

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

I did find I could press Ctrl+Z a few mins after posting, but this still involves pressing 3 keys, but in the 2nd of my options as you can press any key, you can press “=” next to back space key so in comparison you have:

[=] then [backspace] then [return] (all three keys together, so quick to do)

[ctrl] together with [z] then [return] (Z is at other end of keyboard so actually takes longer)

But thanks for reply, it’s still a good alternative.