How to achieve smooth mouse wheel scrolling in LibreOffice Writer (Windows 10)?

By default scrolling is “jumpy”. It instantly jumps by x pixels instead of scrolling whole document frame by frame.

You can achieve this by going to Tools > Options > Libreoffice Writer/Web > View

Make sure the “Smooth Scroll” is enabled.

1 Like

Does not work. This option does literally nothing on Windows 10. It also didn’t work in Libreoffice 5.

Same here. Does nothing on windows.

Still doesn’t work.

I can make Word 2010 scroll the same as LO if I turn off Smooth-scroll list boxes in System Properties > Advanced (search for systempropertiesadvanced next to Start menu) but the setting makes no difference to LO.
There is a Smooth scroll setting in LibreOffice, Tools > Options > LibreOffice Writer > View but it seems to make little difference.

Reducing the number of lines the mouse scrolls (Control Panel\All Control Panel Items\Mouse) makes it appear somewhat smoother. At a scroll setting of one line at a time LO is smoother; Word 2010 or FireFox also scrolls one line at a time but with less acceleration (slower?) so it appears less jerky. All three programs cannot scroll with the mouse wheel a smaller distance than one line (standard Microsoft line?) at a time so it is an appearance thing, not an accuracy thing.