How to add endnotes [solved]

In the docs it says:

Inserting footnotes or endnotes

To insert a footnote or endnote:

  1. Click right next to the text you want to reference.
  2. Click the footnote or endnote button from the Standard toolbar.
  3. The cursor will be moved to the footnote or endnote area, prompting you to type the text.

But there is nothing like this when I right click.

Inserting and Editing Footnotes or Endnotes wording is different:

To Insert a Footnote or Endnote

  1. Click in your document where you want to place the anchor of the note.
  2. Choose Insert - Footnote and Endnote - Footnote or Endnote.
  3. In the Numbering area, select the format that you want to use. If you select Character, click the Choose button and select the character that you want to use for the footnote.
  4. In the Type area, select Footnote or Endnote.
  5. Click OK.
  6. Type the note.

I believe you used some wrong reference; I was able to google that text you mentioned, somewhere outside of LibreOffice help, in a page under website.

Still, there are such buttons there on the toolbar - just the images could differ, depending on the chosen icon set.

I believe you misread/misunderstood the text. “Click right next to the text” didn’t tell you to right-click; it asked you to click in a spot located immediately (“right”) next to the text.

Thanks. What do you mean by buttons on the toolbar? Which toolbar?

Lol. The “Standard toolbar”, mentioned in the point 2 in the steps that you quoted :slight_smile:

Nothing like this on my standard toolbar.

OK. Thanks. Nothing like that! Very few things on my toolbar.

Possibly because I have imported my settings from ooo.

In ooo I used to be able to right click on the toolbar and add or remove icons. Nothing happens in libre.

Did a search and see to go to Tools - Customise. But there are so many options! I take it there is no drag and drop interface like ooo?

And I can’t find insert endnote anywhere!?

This is version

Likely. Using settings from such a thing would bring you many more funny surprises later…

Which exact DnD interface you mean? Please describe what works there, and not here. It might be a bug needing a fix.

“Endnote” it is on your screenshot. Hovering over it would even show a tooltip.

Thanks for your patient help. Added ‘endnote’.

Still nothing.

This is me!

where is the any key?

But you do not show the standard toolbar.

OK. Thanks. Added that. Still no!!??

Insert footnote but no insert endnote.

Please show a screenshot of the customization dialog - similar to the one where you looked for “Insert Endnote” element - with the Endnote added on the Standard toolbar.

Nothing about endnote or footnote

You wrote, that you added it. Did you click on the button, checked that it appeared on the right panel, and that it had a checkbox next to it, and then pressed the OK button?

Anyway, your Standard toolbar only has two buttons enabled. Your toolbar shown on screen (with the footnote button) is definitely not that Standard toolbar. It would be very difficult to try to understand what the mess was created by importing a profile form an ancient thing like Apache OpenOffice. Try to reset your user profile, and work normally.

Or use the menu advise, given in the official documentation, that I quoted above.

Seems I did not manage to add it.

Double clicked on it and it showed up in that list on the standard toolbar.

Still not not show on actual toolbar.

Seems weird that so many things are on the actual toolbar that are not in the dialog - like insert footnote.

The new entry has an x next to it