How to alter default separator when exporting to csv file

When saving a calculation sheet as a csv file LO asks to define the separator suggesting a “,”.
Howevere when selecting another cahcracter - for example a “;” - LO does not store this setting somewhere; so when preferring another character than “,” in general each time this setting has to be retyped on each export.
Is it possible to change the default settings for the separator for csv exports?


AFAIK is not currently possible. However, even if it is not stricto sensu the answer to your question, the future version 5.4 memorizes the export parameters. See release notes & tdf#55236.


File > Save As. Choose .csv under Save as type. Tick Edit filter settings. Save. Choose Keep current format. Choose the separator.

If this helps then please tick the answer and/or show you like it with an uptick.

Some seem to ignore the asked question and prefer instead to answer something they imagine, and for some isn’t a single case.