How to connect LOBase to use MariaDB-created DB

Trying to migrate a large project from MSAccess to LOBase & MariaDB.

I have created with MariaDB a small test DB which contains a single table and two records. When I try to connect to it using LOBase Connect to External DB/MySQL/External connect/Direct Connect give it DB name, User Name and PW and it appears to connect.

BUT looking at the Tables area in Base, I can see all the DBs in the folder listed as if they were tables, with the tables within them as sub-items. This includes MariaDB’s DB controlDBs! I just want to see the tables for the DB I’m connecting to.

Secondly, if I open the table in my testDB, I can see the contents, but cannot add data.

I’ve searched Google for LOBase/MariaDB and OOBase/MySQL and all permutations and only come up with obsolete tutorials that don’t work. Can someone point me to some help on this subject. I’m kind of going crazy and the client wants something to see soon!!!

I’m running on Ubuntu 13.04/Raring Ringtail.

After much search and research and a little luck, I figured out the answers to my questions, plus a further clue. For others who encounter these problem:

First Solved Problem, Seeing all MariaDB databases:
This appears to be normal with MariaDB, when first linking to the database. When, instead, I come in by double-clicking on the Register database, I see what I want: only the current, appropriate database.

Second Solved Problem, Tables are read-only:
Tables created using MariaDB and terminal window are read-only. However, tables created within Base are fully enabled.

Further hint:
I was unable to open the database by double-clicking on the Registered Name in my file manager. I found that I’d created a different username in the CREATE statement in MariaDB than the one I was using for username logon in Ubuntu. ReCREATEing the username in MariaDB fixed that problem.

Now to do some real work!