How to: Connection to Base to Embedded

Connection to data source not established,
LibreOffice on Windows 10 Build 18363 HSQLDB Embedded with Java JRE 1.8.0_271

In my attempts to better understand Forms Filtering I downloaded Villeroy’s FilterData.odb from

I copied FilterData.odb into my learning folder, Registered the Database, and still get:

General error: org.hsqldb.lib.FileSystemRuntimeException:
The connection to the data source “FilterData” could not be established.

Thank you. I look forward to your guidance.



Then make certain the settings in LO are correct. From Menu Tools->Options and then under LibreOffice->Advanced insure a Java version is selected (dot in circle left of Java version) and ‘Use Java runtime environment’ is checked.

Thank you, Ratslinger.

JRE IS installed and other (created here) .odb’s work.

Both 32 and 64 but versions are installed and enabled.

I’ll check back in the morning.

If other Base files work then not certain where your problem lies. The noted Base file does contain macros but I had no problem on Ubuntu 20.04 with LO v7.2.0.0 alpha or v7.0.4.2. Also checked on Win 10 19042.804 with LO v 7.0.4.x but I don’t use Oracle Java. Instead:

AdoptOpenJDK 11.0.8

No problem running the Base file in either system.

Thank you again, Ratslinger.

I uninstalled Oracal Java, downloaded and installed AdoptOpenJDK 11.0.10+9 HotSpot (the default) and made sure that it is selected ( Menu Tools->Options ->Advanced (dot in circle left of Java version) and ‘Use Java runtime environment’ is checked.).

I got the same error!

Next, I deleted FilterData.odb, downloaded it again thinking that I might have a corrupt file.

I get the same error. Of course, no error code, no hint as to what is going on…

Thank you again for your time and suggestions.

Frustrated Fred

Sorry but don’t understand why the problem especially with the error you are getting. Not certain filing a bug report may help (although it can’t hurt) - Bugzilla.

You probably already have this link but will present as more filter examples →
[Example #1] Filter/Search with Forms (leveraging SubForms)

Also there are many posts on the Ask site with filter examples using macros and without.


Have also run across the same error in another post of mine → Charts in Base forms. The error is in one of the comments. Again seems to point possibly to settings. See also my answer-> here

Thank you, again, my teacher.

Bug report 140628 has been created.

My next step will be to completely delete LO. including the …\libreoffice\4\user as there are files from 8/20/2015. I don’t remember how many times LO has been updated since then.

Unrelated: My filtering form - subform -subsubform queries show me what I want, now how does one get the last Table Control selection (click 1 of many rows) saved into the tables?

Again, thank you!


Keep in mind my version in Windows used is as v7.1.x has other bugs that affect my various other files. Don’t see a need to reload LO. Possibly just reset user profile → see this post

As for the “Unrelated”, that should be its’ own question. It is also not clear as to what you are actually asking. More information is needed and details of the problem. Queries, depending upon the content and relation of this content, need specific formation in order to update tables. Can’t have scattered or multi-table data interspersed.

Thank you, @Ratslinger.
Resetting the user profile as suggested by the Bug Report procedure did NOT solve my problem.

I completely deleted LibreOffice from my machine, downloaded, and re-installed it again. Now, the file in question did open!

Note: Old files left behind by the many updated may have been the cause of the many crashes as well.

If I do not figure out how to save my form-filter results to a table I will be back with a more intelligent question.

Again, thank you!


Saw your closed bug report. Based on that it appears you are using a 32 bit LO. Is that correct? Have had various problems with that in the past.


Yes, LibreOffice would often crash in the past. Of course, I got no feedback from the crash reports.

It is too late to give a definitive answer to the “using a 32 bit LO” question. I had thought that I was using up-to-date 64-bit Lo. .

LibreOffice did exist in “C:\Programs Files”, "C:\Programs Files (x86), and in …\Users\FKlus\Roaming. I deleted all of those.

Now I have “C:\Programs Files\LibreOffice”.

The Lo shows Ver. (x64)

Being in the x86 folder, you were using a 32-bit LO. That with whatever in roaming may have been the major part of your problem.

Would expect you uninstalled LO and not just deleted them.


Just noticed you had 32 and 64-bit installed & roaming. Certainly a concern.

Just a guess: Most users (myself included) assume that LibreOffice updates do the necessary cleanup with the updates. I never bothered to even look at what was there before, or after.

My reasoning now is that if the Windows PATH goes to “C:\Programs Files (x86)” before “C:\Programs Files” then, even starting the 64-bit version, 32-bit files would be chosen!

I just looked at my CURRENT path (using Cmd). There is no entre for LibreOffice. I do see several references repeated, For example, every C:\Windows???; is repeated later by C:\WINDOWS???; .

The first entry is C:\Program Files\AdoptOpenJDK\jdk-\bin;

I see later:
C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;
C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;

They DO NOT container the same file name. If they did, the wrong one could be loaded.

(1 of 2 due to length)


(2 of 2 due to length)

I do not know enough about Windows 10 configuration. I do believe that bad configuration could be a major cause of these failures.

Someone who is up-to-date on Windows might be able to write routines for future updates that would assure the orphan files do not remain behind to cause future and intermittent failures.

Again, thank you for your help.
– Fred

Please ignore last now deleted comment. Misread your statement.

:slight_smile: I am sorry, @Ratslinger, I cannot ignore it. :slight_smile:

You deleted it before I could see it.!

No worries here.

No, it is still in your notifications → red envelope next to your User Name near top center. Possibly should read → Ask/Getting Started - The Document Foundation Wiki

Delete and re-install LibreOffice

Thanks to the guidance of @Ratslinger I downloaded a new copy of LibreOffice_7.1.0_Win_x64.msi.
First, I backed up all of my files, then proceeded:

For the first run, I selected “Remove LibreOffice from your computer.” Then I searched for all ->LibreOffice<- files and folders (directories) and deleted them.

The second run of LibreOffice_7.1.0_Win_x64.msi installed the programs.

Cation: If you created any Templates, you must save them again from your backup.

Due to a lack of points, I am not authorized to accept this answer