How to control x-axis date labels in a Calc chart

I have several line graphs that update as I add data. As I have added more and more entries, one of them automatically started not showing the x-axis label for EVERY data point as it got too crowded. They’re separated by a month. But the others all continue to try to cram every label in creating an unreadable sloppy mess.

I’ve looked at the scale settings and date format settings in the x-axis format dialog. They look the same, and neither looks different. I don’t understand why one behaves one way and the other doesn’t. I definitely want the month-skip labels. How can i make that happen?

Please upload your ODF type sample file here.

Right click on your chart and select Edit. Right click on one of the x-axis labels and select Format axis. In the X-axis dialog, select the tab Label. There are a number of options to solve the crowding issue, ticking Break might be the one.

Personally, I tend to to set the alignment at 75 or 90 degrees and automatic, that way I see all points, or if too tight, the most possible points.