How to correctly use LOEclipse?

I’m trying to follow the info at to create a simple Java-based LibreOffice component in Eclipse. Unfortunately, creating a new project with the LOEclipse plugin results in an error and no skeletal implementation file.

For example, I try to create a new LibreOffice Extension project named MyExt. The result is a messagebox that says, ‘Could not find “/home/David/Projects/LibreOf…e/example/comp/”. Please check the spelling and try again.’ No implementation source file is generated in the skeleton project. The Error Log includes the item “ERROR: No such file <file:///home/David/Projects/LibreOffice/MyExt/types.rdb>”.

If I manually introduce an implementation file and try to run the project, the result is a messagebox stating “Error launching configuration.” Error Log details state, “java.lang.reflect.InvocationTargetException: JAR creation failed” along with an exception stack trace.

Searching around, I’ve found no one else having a similar problem, so my guess is it’s something I’m doing. Any ideas where I’m going wrong?


Have not tried this before (although started to a while back but lost interest) so I thought I’d give it a go. Took a slightly different approach than your question (geared more toward a new component) although it seems you moved toward an extension.

Started here as your link didn’t make it clear which Eclipse to install. Already had 2 others & knew they weren’t right. On that same post is a link to this starter extension. Downloaded everything, imported the project, configured LOEclipse, then RUN! LibreOffice started. Since the extension was for Writer, opened Writer and there it was, new menu item & toolbar icon. Entire process was around 90 minutes (some downloading was slow).

Hope this helps.

Hi. Not sure which Eclipse I have installed, but, like you, I’m able to run the starter extension with no problem. My problem is when creating a new extension using File->New->Project->LibreOffice. Doing so and selecting “Extension project” elicits dialogs for configuring the new project. Finishing the dialogs results in an attempt to generate the new project, but the resulting project is broken. Do you get the same result, or are you able to successfully generate a new extension project?

This is the Eclipse - Eclipse IDE for Eclipse Committers

Just saw you message. Opened Eclipse. Closed existing project (original test). Selected File->New->Project->LibreOffice. Chose ‘Extension Project’. Next. Gave it a name - ‘SomeTest’ & all rest defaults as set. Rest of dialogs left all default values. Clicked finish & got new project ready for putting in the code for actual extension. Took all of about 5 minutes.

No errors? Okay…
Do you know if it’s possible to install the Eclipse IDE for Eclipse Committers along side my existing Eclipse installation, or do I have to rip that out first?

I currently have Eclipse for Java & C++ installed along with Committers now. Don’t see a problem. Do not need to remove other Eclipse products. This is why I searched for the first link in my answer - it stated “The Eclipse IDE for Java Developers will not work.”

Not certain what Eclipse you are running since you state you are able to run the starter extension. Wouldn’t think you could without correct Eclipse.

Unfortunately, I can’t discern what Eclipse I’ve got from either repo or About info. All I can tell is it’s “Eclipse Platform Version: Neon.3 (4.6.3) Build id: X20170404-1016”.

I remember running across a page similar to the one you noted and, at the time, figured the Committers IDE was needed for development of the LOEclipse plugin itself, not to use the plugin. Guess I’ll have to give the Committers IDE a try. And broaden my thinking. :slight_smile:

I’ve been using the Eclipse Installer from Eclipse (Linux) for a couple of years now. About info for Commiters:

Eclipse IDE for Eclipse Committers

Version: Oxygen.1a Release (4.7.1a)
Build id: 20171005-1200

About for Java Developers:

Eclipse IDE for Java Developers

Version: Mars.2 Release(4.5.2)
Build id:20160128-0600

@techsquirrel Just an FYI. After many hours of trial and error (multiple docs & internet searches) I finally was able to generate a working component (basically the same setup-up as stated above) . This is why I looked at the project in the first place. Can now cross that one off the LO bucket list.

Well, @Ratslinger, I really appreciate all of your help, but… I have the same problem with both Neon and Oxygen Committers IDE versions. Additionally, they each put up a dialog stating “Your ‘*.java’ file was opened in an external system editor” along with references to changing file associations, so that’s the next clue to dig into. It all leaves me to conclude that my system’s really mucked up. Glad you were able to get a component working. Nice to know some good’s come of this effort.

Sorry to her of your continued problems. Don’t have any further advice for you as I just tried again and still don’t see a problem. I do see one difference but can’t see why it would matter. From the start I have always used the default workspace (in this case “eclipse-workspace”) for retention of projects. I only deviated on the component - source/project in default but resulting .otx in a newly created directory.

Well, if I can be of any other help don’t hesitate to ask.

Tried the default workspace with no joy. Didn’t think it’d help, but it was worth a try. I’m starting to think this might be kernel-related. I’m running 32-bits. I know there’s a 32-bit kernel glitch that can muck up Java in LO and I’ve applied a kernel option workaround for it, but the same glitch may be causing this where the workaround is ineffective. Are you running 32 or 64-bits?

Didn’t think the workspace would help either. Using Linux Mint 18.2 Cinnamon 64-bit with kernel 4.8.0-53 right now. All software is 64-bit.

In the interest of eliminating the impossible, it looks like it’s time to migrate to the 64-bit box that I’ve had sitting around since August. Probably take a week or so to get to it. FYI, I’m currently using Fedora 25 XFCE 32-bit with kernel 4.13.10-100.

@techsquirrel Whilst I was idle, had another thought. If you look at my original answer, I started at a different post. Have you followed those instructions? I’m specifically referring to the “Development” section.

Didn’t seem logical. I understood the “Development” section to be directed to development of the LOEclipse plugin itself. But since you’re saying you followed those instructions and were consequently able to make the plugin work properly, I’ll be trying that tack to see if it helps before proceeding.

Couldn’t follow the ‘Developer’ instructions. Fedora’s repo (RedHat-based, not Debian) lacks at least ‘libreoffice-dev’. Consequently, there’s no easy way to be sure the right stuff’s installed if it didn’t work. So…

I assembled a 64-bit machine (Mint 18.1, LO and libreoffice-java-common preloaded). Loaded on only Oxygen Eclipse IDE for Java Developers, libreoffice-dev (for the SDK), and the LOEclipse plugin. It worked perfectly! My flaky system aside though, your original answer referring here, @Ratslinger, was technically correct. Thanks for all the help!