How to delete a page break without losing the heading format from next page

My headings are not adding page breaks, I manually added a page break before a heading. Now I want to delete it. I have followed [1] but when I put the cursor before the first character on the next page and press BACKSPACE Writer deletes the heading number and all chapters are renumbered using the previous chapter number.

I have searched this site and others but could not find anything about this specific situation. Sample document can be downloaded from:

[1] Inserting and Deleting Page Breaks - LibreOffice Help

OS: Debian

Installation using apt Debian packages.


Compilation ID: 1:6.4.1-1

Two methods:

  1. At the beginning of your heading, press Ctrl Back Space
  2. Right click on the heading after the page break → Paragraph → Paragraph → Text Flow tab → disable the page break
  1. Ctrl + backspace does the same as backspace, at least for me. So no go for this one.

  2. This method worked, thanks a lot.

In advance of removing the page break ‘Before’ from a heading paragraph of your document perform the following steps:

Goto last paragraph (ordinary text) on the page above.
Insert an empty paragraph.
Via the context menu of the new empty paragraph >Paragraph>Paragraph create a pagebreak ‘After’.
Goto the first (Heading) paragraph on the next page again.
Now remove the pagebreak ‘Before’ via the context menu.
Return to the recently inserted paragraph and delete it.

That’s really simple, isn’t it?

This works too. But there is no need to do all that. As the user RGB-es solution suggests you just need to do the second part of your answer.

I felt sure I had already tried this without success (numbering not preserved).
Tried again now, and it worked.
No clue.
I will therefore delete my answer tomorrow if no objections are posted.