How to delete media objects in LO Writer Version:

Currently using Liberoffice Writer Version: Build ID: 420m0(Build:2) on Ubuntu 14.04 LTS.
Started with an earlier version and a blank doc…about a year ago…generated 25 page doc…exported to PDF…WORKED GREAT!!

Now, I have request to TRY to see if this package (via export to PDF) will support audio media objects.
So, I tried Insert → Movie and Sound → selected an MP3 to be played for my doc…with link box checked.

a) this did not work in virgin ODT doc

b) I now have an audio object THAT CANNOT BE REMOVED no matter how hard I try.
…frames…foreground, background, etc…I am hoping this a clever setting issue…I am using all defaults, btw.

c) So…just to try to duplicate/investigate…I tried it again…thinking “surely I made some error”…and i now have
2 beautiful FRIGGING BOAT ANCHORS in an otherwise wonderful document…and they CANNOT BE REMOVED.

d) So… I tried area selection, navigator, object selection, moving them off to blank area of page, changing their options/alignment/etc…the FRAMES OF STEEL!

**Summary: Audio Media Objects in Libreoffice Writer can be inserted....BUT NOT REMOVED..**

Kindly request instructions on how to REMOVE THIS MESS from my FILE...and thank you.

I just simulate your situation. LibO 4.2.7 14.04 on a kubuntu machine. Thus, we have the same systems.

  • I created a Writer file - virgin odt
  • Added a video file (mp4; because I don’t have an mp3 file) of 1.5 GB by Insert > Movie and Sound > selected from file
  • Saved the odt- file - without any special settings
  • Opened the file by double clicking on it in a file explorer
  • Clicked the embedded video, clicked the start button and watch it while typing these lines.

I did the same again with another odt-file. After listening briefly to the video attached to the 2nd odt-file, closed the file, opened the file, selected the video and clicked DELETE. The video was gone.

Thus, I could implement a video into a Writer file and delete it again. Question is what is different between your and my situation?

What in detail did you do when you tried to embed the mp3 file?
Please list up all steps taken and the result of each step.

As for the file where you cannot delete the mp3-file. How was it created in the first step? In Writer? Saved always as a odt-file? If not so, what format was it saved in between? Did you consider that the file is READ-ONLY? You can check this by modifying normal text in this file.

As for the pdf-file, I tried to include the video into the pdf-file but was not successful. It seems pdf can not include a media file in an pdf-file. Imagine a video needs to go through a printer.

Including a link is something different. However, I am new to the kubuntu machine and afraid that this failure to incorporate a normal internet link via Writer into a pdf-file, and thus, assume I made a mistake, which I have not found yet.

RESOLVED - Thank you

Hi and thanks for your speedy reply.

I tried your experiment…it also worked for me EXCEPT…I could not delete the “BIG SPEAKER” (audio embedded object).

To improve my tools, I selected View → Sidebar

I was able to verify - this “BIG SPEAKER” is just a FRAME…

I WAS ABLE to DELETE (yay!) as follows:

a) Select “BIG SPEAKER”. On right sidebar, select PROPERTIES → MORE OPTIONS

b) Here is the change that counts: select “Anchor → As Character”.

c) Now move cursor to right (after) “BIG SPEAKER” and then hit the BACKSPACE key (or Cntl-X or Cut icon).

Now temporary and original document working fine.