How to disable drag & drop option in LibreOffice Draw?

I need to disable the drag & drop options even while I hold on an image in libreoffice draw.
Is there any solution for this?
Maybe an extension or any settings hidden would be good.

Are you asking to disable drag in a drawing program? Maybe a more detailed explanation of the problem you are facing and your intended goal might help.

Or do you need to lock pictures in place? Insert > Layer… , add whatever you want to the layer, then right-click on the layer name at the bottom of the screen, select Modify Layer, then tick the box Locked. Anything on that layer then cannot be selected or moved until the layer is unlocked.

Hi, Earnest Al
Thanks for your comment!
LibreOffice Draw supports two options for the mouse down event of image objects.

  • Move (snapping to the grid)
  • Drag & drop (free move)

These options have sightly different mouse icons when they are activated.
What I am asking is how to disable drag & drop, which has the icon contains an arrow and a rectangle, so that I can use the moving feature between grid points only.

I’m not sure there is a way. In Draw I get a four-headed arrow when I move objects as opposed to your description. The snapping is not very pronounced in LO compared to Inkscape. Holding down Shift constrains direction but that is not what you mean. Most of the time I use the arrow keys 1mm, Shift arrow 10 mm, Alt arrow 0.4mm (?), this is based on 10 mm grid.

Free move is assured pressing Alt. May be assigning a shortcut key to togle snap to grid could help.

Also can check in menu Tools-Options…-LibreOffice Draw-Grid.
Resolution of 1 cm and Subdivision of 10 spaces will result in a 1 mm grid. Using a Subdivision of 2 spaces will result in a 5 mm grid.

@EarnestAl, LibreOffice Help shows an arrow with a rectangle. I am working with version and see a four-headed arrow.

That is not a solution I think
I just want to disable the drag & drop function even if you hold the image for more than 1s without moving.
Disabling snap is not related to this problem for sure.

Of course, that showed a four-headed arrow cursor, but it will be changed to drag & drop when you keep your mouse button clicked for a while without moving.
I need to prevent this. :slight_smile:

@headit74, Now I understand your problem. Searched but can’t find a solution. Pressing Esc cancel the drag-and-drop operation, but also unselect the image.

You can post a request for enhancement at

Hmmm. Holding still for 20 seconds (I got bored by then - short attention span) I still keep 4 headed arrow. The only time I see the single arrow is dragging from Gallery when it has a plus next to it; subsequent moves have 4 headed arrow.

Version: (x64), CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: default; VCL: win;
Locale: en-NZ (en_NZ); UI-Language: en-GB Calc: CL

AH now I see, if you don’t start the move within one second it switches to drag and drop. Once you have started moving you keep the 4 headed arrow forever, even if you pause for a long time. I have never noticed thanks to my short attention span.

The answer then is to start the move immediately.

Start the move immediately on clicking the object and you will remain in Move mode