How to disable Font Antialising at OSX Mavericks and LibO 4.2 ?


since “Mac OSX Mavericks” and “LibreOffice 4.2” screen fonts are always rendered (font smoothing, anti-aliasing). I already has disabled „Screen fonts anti-aliasing” in the User interface - but the fonts are still rendered. Apple is obviously keen to enforce font smoothing and thus prevents a free choice.

I had the same problem with Firefox and Thunderbird. In these, however, you can change some values in the configuration-settings (about:config) to disable font Smoothing.

At LibreOffice, you can adjust the configuration values under „Expert Configuration” too. Unfortunately, I don’t know which value I should change.

Which configuration values do I need to change so that font antialising is disabled?

Please help me!

Thanks for feedback! Bernie

Change Font Anti-aliasing & Font Smoothing Strength in OS X Yosemite
Changing the font smoothing strength requires using the Terminal app and defaults command strings. Having tested this for a while in Yosemite, it appears there’s only really three options available in Yosemite, regardless of the integer number attached to AppleFontSmoothing. OS X Yosemite defaults to using AppleFontSmoothing “3”, and there does not appear to be any visible difference between setting it to “2” or “1”, which in either case results in a lighter font smoothing setting than the default. Setting it to “0” is the same as turning it off in the preference panel, which again, doesn’t completely turn off font smoothing, it just reduces it to an even lower strength of antialiasing.

Set a Softer Font Smoothing Setting
Enter the following defaults string into the Terminal and hit return:

defaults -currentHost write -globalDomain AppleFontSmoothing -int 2

You’ll want to log out and log back in for the change to appear everywhere.

It’s important to note the differences are subtle, and many users probably won’t be able to distinguish one from the next. If you have a retina display, anything other than the default option may look poor to you.