How to edit Base -> MariaDB tables

I’m using Kubuntu 19.04 with LO, MariaDB 10.3.13 and the libreoffice-sdbc-mysql package. I can connect to a local or remote instance of “mysql”, create tables and view already created tables but always in read-only mode. I’ve added a primary auto_increment key as suggested in some posts but I still can’t add or edit rows.
The mysql database user has ALL perms to the database and everything seems fine in phpmyadmin when looking at the same databases and tables. I’ve seen a suggestion to “save as” first (but I can’t as it’s a greyed out option) which suggest the SDBC MySQL driver is perhaps buggy? Any suggestions as to what to try next?


Have just confirmed your problem. You should reported the problem here → Bugzilla.

I personally do not use Debian nor MariaDB (set up only for testing/answering questions). This has worked in the past with a native connector. However, with the release of LO 6.2.x there was a change in the native connector. Previously you needed to install an extension which, for me, worked without a problem. Now the MariaDB connector is used; see → LO 6.2 Release Notes. Even with the extension installed it is overridden. This does not allow, as you stated, data editing in tables. I have also seen different problems with this connector using MySQL (mainly in macros).

Did a quick test using MariaDB & Base with JDBC connector and saw no problem. This (or going back to a pre LO 6.2 version) may be your only current option for connection.

Just tested LO with MySQL on Mint 18.3 with native connector. Same problem as with MariaDB - cannot add new records. JDBC is OK.