How to email Libre Office Calc Sheet so that it can be edited by recipient

I understand if I use Thunderbird to send a spreadsheet by email, that there is some way it can be edited by the recipient, so that she can enter input and send it back to me.

I went to Tools / options / then entered my email address
and then to File / Send / email as Open document spreadsheet,
but I have not been successful, what am I doing wrong please?

Should I download Microsoft Excel in order to do this please?

p.s. the document when received by email was a ‘read only’

The easiest way to send is to just drag the file from the file manager onto the Thunderbird new email pane.

The recipient normally has to save the attached file to a folder somewhere to edit it, just like you can’t edit a received email but you can edit a copy.

Incidentally, my version of Excel refuses to even open an attached xlsx file until it is saved to a folder and even then in read-only mode.

No matter how you send an email, any attachment needs to be copied into a folder in order to be editable.
This way, the recipient is forced to make a decision about where he wants to save his own work without modifying the received email in his inbox.

You want to send an email with Excel?

Thank you…I copied the document using Control C and Control V onto the Thunderbird email page, sent it to myself as I am signed up to Thunderbird and my colleague is not yet.
When I opened the email, I clicked on ‘save as’ a document in a folder but I am unable to edit that, so I don’t know what I am doing wrong…sorry, any comment appreciated. thanks

thank you, no not necessarily Excel…just any way that it will be successful.

We can not know what you are doing wrong. You do not even tell us your operating system, let alone where you store the attachment for editing.
Solution 1: Open the document read-only and click the edit button on the blue banner which tells you that this document is read-only. You will be able to edit the document. Before you can save the modified document, you will be forced to choose a folder where you are allowed to write to. Just choose your documents folder or any subfolder therein.
Solution 2: Save the attachment to a folder where you are allowed to write to, and then open that file in the chosen folder.

I suspect you only copied a text-copy from Calc to Thunderbird.
Don’t work inside LibreOffice here. Just save and append the .ods-file as attachment in Thunderbird. There is a button to the top right of the composer-window (and if I use suspicious words like append, I also get a reminder bar in yellow to attach something). All you need to know is where you saved your file…

1 Like

I will assume you are using Windows for this comment

Is Thunderbird the default email client for Mailto?

If I click File > Send > As Open Document Spreadsheet then Thunderbird creates a new unaddressed email and adds it as an attachment with the filename (without extension) in the subject line. I would just need to add an address and any covering text to the email.
Personally, I always just drag the file from the Explorer window to a new email window as this does not rely on setting a default Mailto client.

If you receive an email from someone (not yourself) and save it somewhere, it will be marked as coming from an Internet location and will initially open as Read-only. A blue bar will give you a warning it is in read only mode and a button to Edit Document.

Very occasionally, Windows will block the file. If the file is known to be safe then you can unblock it by right clicking on the file, selecting Properties and unblocking it. You can also unset a read-only status here.

Your antivirus might also block files; to solve this you need to read the manual

Version: (X86_64) / LibreOffice Community
Build ID: e19e193f88cd6c0525a17fb7a176ed8e6a3e2aa1
CPU threads: 8; OS: Windows 10.0 Build 22621; UI render: Skia/Raster; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: CL threaded

1 Like

Sorry took long time to get back… I am using windows. And saved a copy of the LO spreadsheet to a separate folder. . My laptop is HPLAPTOP-0JG0MEVE .
However the copy doesn’t come with the LO bar across the top, and when it is sent, doesn’t give me read only or the option to change it. It looks as though Thunderbird has downloaded all my emails, without my requesting that so perhaps TB is my default email mail to. Does it have to be the default mail to in order for this to work? My colleague I want to send these to says she has been told that it’s not compatible with her system. I don’t know what the implications of that are, She has advised me to use Excel as she uses excel but am so used to LO and like the way it works. Is getting Excel myself the only way it will work then? thank you for your patience.

Which folder?

Then it is writable.
If not, menu:File>Save As… and choose your documents folder.

This has nothing to do with Thunderbird.

Your colleague should be able to open .ods spreadsheet files on a recent version of Microsoft Office. You could File > Save a copy as .xlsx to send if they really cannot open the .ods file.

If you are going to be working long term together on the same documents then you should both use the same software, preferably the same version. This will avoid conversion errors that will accumulate each time the document is opened. If your colleague cannot afford LibreOffice, then consider buying Excel or MS Office.