How to fix a faltering cursor

LibreOffice Writer, version 7.01, JRE 10, Windows 10, last upd.
In LO Writer the cursor is quite annoying.
When a character is entered, it will immediately appear on the screen.
LO then waits a second and then continues to display the characters already typed in.
You can say the cursor falters.
It is with every character of the keyboard.
This also happens in Safe Mode.
It doesn’t happen in Calc and Impress.
Reinstalling doesn’t fix it.
This does not happen in any other installed program.
Running AntiSpyware doesn’t fix it.
Please Help, this is driving me crazy.

18-06-2021 Additional info.
LO installed version is 7.1.4.2. Already been reinstalled twice.
The cursor does not falter in a new text document.
I have copied the contents of the “falter document” into new, empty document.
Guess what, cursor shows no problem.
After an hour the cursor started to falter again.
The document works with Bullets and Numbering and Index.
My other documents, also with Numbering and Index, do not show a “faltering cursor”.
Rewriting the entire document is not an option, it contains 592 pages and 105,000 words.
But wait, the document opened in OpenOffce 4.1.1.0 does not show a “faltering cursor”.
So LO must be the culprit.
In the meantime any suggestions?

LibreOffice Writer, version 7.01

I’d suggest to give a more recent release a try (7.0.6 or 7.1.4)

@ArthurCerew, The cursor hides after typing a character? The cursor is displayed as a character?

When started this behavior?

Have you tried to deinstall and reinstall LibreOffice?


Add Answer is reserved for solutions. Please, click edit below your question to add more information.

LibreOffice >= Version 7.0

If set, try to disable Skia in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use Skia for all rendering and check whether that fixes/mitigates your problem

In what format are you saving the file?