How to get a screenshot of a LibreOffice alt menu?

I’m running Ubuntu 18.04, up-to-date on patches.

Using LibreOffice

I ran into a problem with the alt menu and tried to take a screen shot. Clicking on the Screenshot program causes LibreOffice Writer to close the open menu. Makes sense, Writer isn’t the active window.

I tried using the PrtScn key but nothing happens while the alt menu is open. If I close the menu the PrtScn key works as expected.

Is there a way, without pointing a camera at my monitor, to get a screen shot of the LibreOffice alt menu?

File menu using Alt-F

File menu using F10

What is the “alt” menu? Which kind of user interface have you selected?

I added images to the original question.
I ran into a bug where Alt-F, s would sometimes open a spreadsheet instead of saving. I wanted screenshots to go with the bug report.

Why don’t you use simply Ctrl+S?

Decades of muscle memory. Alt-F, s has been used for saving for a long time.

Yep, very difficult to force a new habit. I know. But Ctrl+S is two strokes, Alt+F then S is three.

Yes but Alt-f, s works with many, many applications.


Screenshot allows you to grab the current window with a delay (desktop or current window).

Set delay for 5 - 10 seconds, start and do what is needed on the document. Here is Writr with Alt key held:

image description

Please note - This is not actually a question about LibreOffice.

Thank you but it did not work for what I wanted. All I got was the Writer window without the menu despite the menu being shown when the screenshot was taken.

I can see what you mean about not being a LibreOffice issue. But if LibreOffice didn’t block the PrtScn key while the menu is shown I wouldn’t have this problem. Plus, people working with LibreOffice have probably figured out how to do this already.

I apologize, I was wrong, your answer does work.

I originally tried it selecting the “Current Window” and it failed as I said.

But I just tried it by selecting “the whole screen” and it did get the open menu.

Thank you


I have used current window, Ubuntu 18 & now 20, for years now (screenshot in answer). Not certain why it did not work for you.

Glad you got something working.