How to get Impress to open .fodp on Windows

When I try to open a .fodp (flat XML) file with LibreOffice Impress, the file opens in Writer instead.

Oddly, when I first installed LibreOffice I was able to open in Impress. So maybe some Windows update is interfering.

Windows Explorer recognizes the files as a LibreOffice Presentations, but for some reason the files keep getting directed to Writer when I go to open them.

I’m using LibreOffice Version:

Thanks in advance!

Got the .fodp files to open in Impress after I re-installed LibreOffice (same installer). Not sure what fixed it, or what the original cause was; but this time I used the typical settings instead of doing custom ones.

Please accept your answer, by clicking the little grey check-mark to the right of the text of your answer.