How to get rid of the space under a table inside a table cell?

Hi, I am editing a document and I want to insert a 3 rows by 2 column table inside a cell of an existing table. Whenever I insert the nested table, It has this space under it which I don’t have any idea on how to get rid. On the other hand, I tried creating a table within a table on a blank document on Libre office, It doesnt contain that space under the nested table. I have tried checking whatever property that’s making the space under the table but I couldnt figure it out. I could even resize it. Please help. Thank you so much , ,

this one doesnt seem to have the problem

A new table is a different object and the space (padding) of the borders of the containing table are more than 0 by default. You may set the spaces to 0 and there will be nearly no gaps between container table and inserted one.


Have you thought about splitting a table cell into horizontal and vertical parts? There won’t be any gaps.

Hi thanks for this but I have set the space to content of all sides to 0 and still, when i add the table inside the cell, there is still space right at the bottom. I cant split the cells because the document will be processed on apache velocity as a template and this cell will have the ability to be repeated if needed during processing depending on the data inserted. , ,

this one doesnt seem to have the problem

You may already have a paragraph in your container cell. When you insert a table flushed to left/right margins , this paragraph wraps to next line and occupies space according to its spacing.

To make sure, display the formatting marks (menu Display>Formatting marks or key Ctrl+F10). Paragraph marks show as “pilcrows” (mirrored P).

If you have such a paragraph mark (and no other text) after your table, put your cursor before it and press Del.

EDIT 2018-03-11

Eventually, have a look at Tooks>Options>LO Writer>Compatibility Add spacing between paragraphs and tables (second item from top).

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

Yes, I did that too, but the paragraph was not deleted.

Caution, make sure you press Del, not Backspace

Yep, Del and backspace doesnt work. Pressing del only moves the cursor inside the nested table. I am willing to have someone remote access my pc and see if this issue can be fixed.

If you’re moving inside the nested table, you didn’t position the cursor to the right location. It must be set after the nested table. If you can’t click there, use right arrow to go.

Your screenshots don’t display the formatting marks. This would helpdiagnode the problem. Press Ctrl+F10 and repost the shots.

I think your issue is unrelated to nested tables but the table creation itself. when I create a new table a paragraph is inserted at the beginning & end. the former is easily deleted but the best I can do with the latter is to change the font size to 6. I complained about this a long time ago without resolution. good luck.