How to get writer tables to appear after creating them?

Version:, 0ubuntu0.18.04.10 Created a table in writer, and it appears as a gray box.I can blindly enter text in cells, convert table to text, and see that what I’m entering is going in as cells, cols, rows, etc. But the whole table is just a gray rectangle. How do I get it to appear?

Have a look at Tools>Options, LibreOffice Writer>View. Is the checkbox Tables ticked? If not, tick it.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

You’d think they’d put stuff like that in the help for tables.

I think this checkbox is enabled by default (at least in my distro). You may have played a bit with settings and forget about it or also mistyped a Ctrl+Shift+ … + something which apparently had no effect but changed the setting. You can never telle.

You’re probably right. Also, there’s a Tools->Options->LibreOffice->View dialog, which is NOT for Writer.
Also, the table when “not shown” is set to all gray, and is NOT “Not Shown”. That is, the table still works in its entirety, you just can’t see what you’re doing. I can’t think of any useful purpose in such a definition of “not shown”: It doesn’t reduce CPU/memory loading, as the table’s all still there; It doesn’t speed things up for the user, same reason; it takes up just as much screen real estate and document scrolling space. There’s no real advantage to the way it’s implemented, unless the purpose is to confuse new users.

I had a look at Tools>Options, LibreOffice>View; There is no (duplicate) Tables checkbox here (in my version). This group of settings is for general display configuration (hardware acceleration, anti-aliasing, …).

When tables are not shown, they are not shown (again, this may be a change with my more recent version). The table space is shown gray only when the cursor is inside the table. The space occupied by the table is relatively easy to compute and you can skip this area in a WYSIWYG app to show what’s really used up by the invisible object. That’s part of WYSIWYG. Since you don’t hand out the content of the table to the font renderer, I bet that you spare CPU cycles. Of course, this is not that important, considering the bulk of the document is made of standard displayed paragraphs.

My machine is powerful enough I never felt the need to hide document objects.