How to help libreoffice find the installed Java runtime?

Hi, I have a PC with windows 10. installed java JRE 8u121 (32 bit) then libreoffice 32 bit
Java 64 bit is not installed

I need java for using Base in libreoffice

Java is recognized in my system (other java app do work with the JRE).

When I open Tools - Options - Libreoffice - Advanced, there is no java runtime which may be selected from a list. Have waited a full night to let the system find it.

I tried to manually set up the directory of the JRE, going through all C:\Program Files (x86)\Java\jre1.8.0_121 subdirectories but got only error messages.

I tried also with an older version of libreoffice, without success.
I also tried to check with JDK instead of JRE ;-(

From what I’ve read in this and other forums, it seems I’m not the only one to have this problem.

Maybe somebody has an idea what I could check.

Thanks in advance

What errors ? Or is it just along the lines of ‘Java not found in folder’ ?

When I try to add a JRE environnement in Tools - Options - Libreoffice - Advanced I put as path C:\Program Files\Java\jre1.8.0_121

the system responds with: (i hope you understand, basically, no JRE found, try another path)
Le dossier que vous avez sélectionné ne contient pas d’environnement d’exécution Java.
Veuillez sélectionner un dossier différent.

by the way, I tested now with both java 64 bits and libreoffice with the same issue

to clarify, I test with negative result both java and libreoffice in 32 bit then in 64 bit. No success, same message.

I wonder if LO doesn’t have the permissions it needs to open the jre file? Might be interesting to investigate what permissions are needed. I don’t know if it’s read, write, and/or execute that is required for a jar. But you might try giving the user running LO full permission for the jre (and also if needed it’s subdirs). Another idea would be to locate your jre on your desktop and then hook that up and see if that makes any difference. If necessary I can explain more in detail.

I had the exact same issue. I spent hours trying to fix it with a 32-bit JRE on my Windows 10 64 bits. Nothing was working … until I installed JRE 9.0.1 64 bit release under C:\Program Files\java. Then I used C:\Program Files\java\jdk-9.0.1 as the path in libreoffice for java runtime environment … and it worked like a charm ! (I installed libreoffice (x64))

I hope this helps.

Yes, this worked for me, thanks. I think the important think is to download the Java SE Runtime environment: and then point LO to it as described above.(It installs automatically in C:\Program Files\Java.

Here are a few screen shots of my working windows 10 LibreOffice which might help you. There are two java things needed, the JRE (Java Runtime Environment), and the JDBC driver.

First where the JRE is located:

How Libreoffice is set up (1of2)

Where the classpath for the JDBC driver(s) are:

How it’s hooked up.

image description

@EasyTrieve there is no need for any driver unless using an external DB.

When I try to open a database (in my case a file flight_data.odg) without having installed java, I get an error “libreoffice requires JRE”, so I think indeed java is needed.

The Options - Libreoffice - Advanced screen is displayed as in EasyTrieve screenshot, but there is no java in the java runtime environnements (JRE) already installed list, to select from. my java JRE is exactly in the same place as in EasyTrieve screenshot.

But I find no JDBC driver as in he’s screenshot.

Humm, I’ve had lots of trouble w/ Java over the years. They may claim it’s installed on 3 billion devices, but I’m guessing that it doesn’t work properly on Windows 10 that much of the time. Try uninstalling it. Then go make sure it’s really gone. Then reinstall. Also I think that Oracle has some sort of Java tester at their web site. Run that. Also there is a Java console that you can run from the start menu I think. (I say I think, because I’m in Debian at the moment, and not in Win10)

Thank you EasyTrieve. I spend another couple of hours installing / unstalling / removing the libreoffice profile. Nothing work. It’s a corporate PC which have policies which may perhaps conflict with Java and/or libreoffice. I don’t know.
I Installed it on my wife’s home PC and it works as expected.

Thank you anyway

Just for other interested,
I confirm that on the successful PC I have windwos 10, java JRE 64 bit (jre-8u121-windows-x64.exe) and libreoffice 5.2.5 64bit

the java console

I have the identical problem: windows10, libreoffice, Jre 1.8.0_121 e 1.8.0_60 (I tried with both).
My pc is a brand new ASUS and libreoffice base is the main purpose.
The error I find is exactly the same described by Jan. After a full afternoon trying to solve the problem I don’t know what to do more.
Thanks a lot for any advice.

Pier Luigi

Every case is specific to what is installed. If you have the 32-bit LO installed then you need the 32-bit JRE. If you have the 64-bit LO installed you need the 64-bit JRE. Also insure you have the Java Options set in LO as pictured in above answer showing settings for Options->LibreOffice->Advanced.

Hi, i did a new install on my desktop pc (w10,LO latest version) and still have these problems. Does anybody haven clear guideline on “what to download from where” and how to tell LO that it should search for installed java in a better (more professional) way. This is the year 2017; why use procedures from 2002?

My self found that installing the JDK for the private jre inside the jdk, enabled much faster advance settings identification of the JRE, did still have to add the JDK threw the advanced tab in win 7 64 bit, and that solved the issues with identifying the java location, and function ability requirement’s for libre office needs to work !

After so many hours of suffering, I tried everything you wrote, libreoffice simply wrote that it only works with 32-bit java… and really! (win7)

I’m unsure how this solves the original question… could you please elaborate?