How To Make Text Selection In Writer Visible?

In the answer to a previous question it was stated by @RGB-es:

LibreOffice use the system color
scheme when possible, that means that
the background color for selected text
(either by direct selection or through
a search function) is determined by
your OS settings. So no, you cannot
change that from LibO, you need to
change the system settings. In my
Plasma system it’s a light blue, for

However, that doesn’t seem to be the case for me:

Above is LibreOffice on a Mac running 11.5.1. Below is Mac TextEdit.

As is obvious, the select text is very easy to see in TextEdit and almost impossible to see in LibreOffice.

How do I fix this?

I also notice a difference between menu item selection (or UI element selection) and text selection on my Linux box. It looks like LO uses the same OS color for text selection but applies less saturation to it. Unfortunately, this looks like it is hard-coded and can’t be modified by user.

The current version of NeoOffice (Mac only?) doesn’t have this flaw. Neither does Mac version of LibreOffice. I guess I’ll be using the older version of LO until 7.x gets fixed.

This is a serious flaw which makes it next to impossible to edit a document. So hard to see what you’ve actually selected.

Try TransparentSelection and TransparentSelectionPercent under org.openoffice.Office.Common/Drawinglayer in Expert Configuration.


This works, but it’s harder to get to than one would think:

Preferences > LibreOffice > Advanced
[Open Expert Configuration]
Org.openoffice.Office.Common > Drawinglayer


Oddly, the default value here makes the selection a.most completely transparent which doesn’t work very well. 40% works for me.


I don’t understand why an essential setting like this is buried in the “Expert” configuration.

1 Like

I don’t understand why an essential setting like this is buried in the “Expert” configuration.

Because out of tens of thousands of questions here, yours about the transparency of selection is maybe the first, and anyway definitely not asked often. It is not an issue that people often solve. It is expected that the default is OK. If it is not, then it should be considered a bug, filed, triaged (does it depend on some special OS configuration that we happen to not take into account? otherwise, why it’s not a problem for others?) and fixed, not a control introduced that is useless for 99.999%.

1 Like

That’s an interesting point. When I first encountered this “feature” I tried to solve it by wading through the preferences menus. Not finding a solution I simply gave up and put up with the inability to see selections well. Finally, I decided to actually search a bit and found this question:

All of the answers and comments therein imply that you can’t change this; thus proving your point that people don’t often solve this problem. In fact, we have no idea how many people are inconvenienced by this and have simply given up trying to fix it.

There ought to be an easier solution.

There ought to be an easier solution.

No. As I mentioned, there ought to be a default that fits everyone. E.g., it ought to follow OS. If it does not fit, then you don’t need controls to tweak it, but you need to file a bug report.

I’m not competent to file a bug report. I’m just an occasional user of LO. Perhaps two or three times a month when my wife (a Thai attorney) asks me to review and edit a Thai/English translation that she’s done. So, my knowledge of LO is extremely limited. The inability to see selected text was particularly annoying because most of what I do is select text that she’s written and change it to more standard English. I never use LO to compose a document or do anything more than simple select and edit. A bug report should be filed by a regular and more sophisticated user.

No. A bug report should be filed by a user that sees the problem, and that is able to answer any clarification questions, if those arise. E.g., I don’t see such problems (maybe just since I don’t use macOS). Bug report is not something static, that anyone is able to file on anyone else’s behalf.

You must restart LibreOffice to see this working.

The answer seems to be to go back to an older version of LibreOffice. This is version As you can see, the selection highlighting is clearly visible.

If you don’t want to wade through menu items to adjust selection transparency, it seems that you can edit the registry modifications file which, on a Mac, is here:

~/Library/Application Support/LibreOffice/4/user/registrymodifications.xcu

The items to look for are here:

<item oor:path="/org.openoffice.Office.Common/Drawinglayer"><prop oor:name="TransparentSelection" oor:op="fuse"><value>true</value></prop></item>

<item oor:path="/org.openoffice.Office.Common/Drawinglayer"><prop oor:name="TransparentSelectionPercent" oor:op="fuse"><value>40</value></prop></item>