How to make Windows search index LibreOffice documents

I noticed that WIndows search isn’t indexing the contents of LibreOffice documents.

Control Panel → Indexing Options → Advanced → File Tyes tab shows “Registered IFilter is not found” for all LibreOffice file extensions.

A long time ago, I had a problem where the Windows search indexer was using all the CPU because of the LibreOffice filters, so I did something to fix it but can’t remember what.

This is LibreOffice on 32-bit Windows 8.1.

I used the SearchFilterView by Nir Sofer to look at the installed filters and found Microsoft filters but none from LibreOffice. I guess this was the fix I made.

The Microsoft filters are OFFFILTX.DLL, described as the “Microsoft Office Open XML Format Filter”, for Excel: .xlsm, .xlsx, .xlsb; PowerPoint: .ppsx, .pptm, .pptx and Word: .docm, .docx, .dotx, and OFFFILT.DLL, described as the “Microsoft Filter for Open Document Format”. The latter has no file tyes associated with it. I cannot find any LibreOffice filters. Are they still supplied? How are they installed? Do they work?

Both Microsoft filters are in “C:\Program Files\Microsoft Office 15\root\VFS\ProgramFilesCommonX86\Microsoft Shared\Filters”.

Using SearchFilterView to add .odt files to OFFFILT.DLL and then looking in the Control Panel → Indexing Options → Advanced → File Tyes tab shows “Open Document Format ODT FIlter” for.odt files. Unfortunately, searching the contents of odt files stil doesn’t work. After a reboot and some time, indexing still isn’t working.

Shouldn’t the filters be located in the C:\Windows subdirectories?

On my Win 8.1. I find 2 versions (slightly different size) of OFFFILT.dll in C:\Windows\System32 and in C:\Windows\SysWOW64. Indexing odf file types is working. A specific filter for LibreOffice files should be superfluous as the structure of the CONTENT.XML is sufficiently specified in the OASIS documents.

There were issues with indexing (Win 7?) where MS told to create the index anew from scratch.

Just my experience: I am using XP and my IT wizard younger brother told me to better switch of the indexing. I follow his advice years ago and have no problem at all when I search for a file; be the file a LibO or any other file.

Do you (or does he) know how to switch on the indexing?