How to mix ltr and rtl langs and maintain proper format

I am trying to mix english with rtl langs words but i get the words out of order.

How to maintain the same word order regardless of the language symbols.

os: windows 10
I did change the language settings in the tools section both for arabic and urdu

Attached an image of the issue. the circled section should be at the beginning and “iOS” word comes after it.

Thank you.

Edit your question to improve it. Don’t use a comment at this stage. It is more user-friendly to have a self-sufficient question than compelling contributors to read a whole thread to try to understand the problem.

Basic information needed: OS name, LO version, save format
What is your skill with style formatting?
How do you write tour mixed text? Better: attach a short sample file.
Have you enabled Complex Text Layout with Arabic language in Tools>Options, Language Settings>Languages?

I suppose that also (in addition to the file) a screenshot with what you actually see, and what you want to achieve instead, would be nice.