How to place a "grand total" on report

I have a report for an accounting database that shows detail for all transactions grouped by category. I have placed totals for the amounts in the group footer. That part works well. I’m stuck on how and where to place a “Grand total” at the end of the report. I want it to show only one time, at the end of the report.

edit: images of properties of the accumulation control, placed in the report footer:

image description


This is nearly identical to the total you already have. Your current accumulation should be based on a scope of the group. For the entire report, place a field on the Report Footer and the accumulation is a scope of Report.


Using this version on Mint 18.3:

Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

I tend to stay away from versions other than TDF or PPA. Have no current problems with group or report accumulation. See if my sample works for you. Simple but effective nonsense report based upon a query.

Sample ------ TotalDemo.odb

Have seen similar problem as you describe in an older version but with a bit of playing around with (don’t remember how I got around it or the exact version this was a problem in) I was still doable. Seems I had to enter & re-enter or maybe even save the re-do - just not sure. This is not a problem in current TDF version.

Edit #2:

Just jumped over to Ubuntu 18.04 Mate and again no problems with this version:

Build ID: 1:6.1.4-0ubuntu0.18.04.1~lo1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

It was pretty easy to place it in the Report Footer, and set the scope to “Report,” but it doesn’t show up when displaying the report. What am I missing? (see images of control properties added to the original question above).

Can’t say for certain since a current test shows it is as simple as my answer states. The accumulation should be based upon the detail of each transaction the same as totaling the group.

Other than this, need to see a sample to figure out just what you have.

Just saw additional information. I’m sure this is NOT how you generated the group totals. Should be something like:

Data Field Type         Function
Data Field                  (choose the field to accumulate here)
Function                    Accumulation
Scope                        Report

This does not work. I’m beginning to suspect a bug.
Here are the steps I’m going through:
1. Place a text box in the form footer.
2. In the properties-data tab of the text box, I select:
◦ Data field type: “function”
◦ Data field: “Dollar_Amount”
◦ Function: “Accumulation” This blanks out the “Function” box, and in the data field box I now have “[AccumulationDollar_AmountReport]”
◦ In the scope box, the only option is “Report.” I select this, but nothing happens. Running the report shows no totals in the report footer of any page.

The result is exactly the same if I start by inserting the data field and then setting it as a function.

Here’s the verion information:

Build ID: libreoffice-
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); Calc: group threaded

I did find a way to make it work. Somehow my system had store the original group accumulations as user-defined functions, and every time I tried to put something similar for the same field in another section of the report, it converted it into the non-functioning user-defined function. This was on any version I tried. To fix it, I gave the fields in questin different aliases in the query underlying the report, and was able to re-do the group and report accumulations correctly. I’m going to mark this solved, in that @Ratslinger’s original answer above is the correct one for the question I originally asked.

@Ratslinger : What is a TDF version?

@dougmn The Document Foundation - Download page