How to print several worksheets/printranges into a single page?


Below I use “worksheet” to mean the different sheets a spreadsheet can have (identified by sheet tabs), not the whole spreadsheet
And I use “page of paper” to mean one page in the exported/printed document.
I’m just trying to avoid “sheet” because it means both a spreadsheet file sheet, and also a physical sheet of paper.

In images:
How to get this:

Instead of this:

In words:
I’m trying to print several print ranges / worksheets in an efficient way, using all the available vertical space on the page of paper. I can’t find a way to do this.

Situation 1:
I have 2 or more print ranges on the same worksheet and I print the worksheet. The print ranges get printed each to a different page of paper. I would like to print them one below the other on the same page of paper.

Situation 2:
I have a spreadsheet with two or more worksheets. Each one has a table on it.
Again, if I select the 2 worksheets and print, each worksheet gets printed to a different page of paper. I would like to print one below the other on the same page of paper.

Note: I don’t mean having a single worksheet with a very big table that spans several pages of paper when printed, I mean having a worksheet with several non contiguous print ranges on it, or having several worksheets each one with a different table.

Problematic solution:
“Put the ranges you want to print on the same sheet one below the other and they will be printed one below the other”
The problem with this solution is that when you put a table directly below another the Column Widths have to be the same. Sometimes this is not a problem because you can adjust the column widths so that both tables look right, but sometimes they’re incompatible and you really need each table to have different column widths, so this is not a good solution.


Possible solution for Situation2:
I found a not very intuitive way to more or less do what I want in Situation2 (which is also mentiond by Pierrre below) by first setting worksheet page orientation to Landscape. Then open the print dialog, go to Page Layout tab and change pages per sheet to 2 (or more), then go to General tab, click on Properties button and change orientation to portrait.
This should work if I were to print the file to paper, but How would I do this when exporting to PDF (the most common thing)??

I’m still looking for a solution for Situation1

I was wondering why this question wasn’t getting any activity when I realized it had been deleted! I might have done it accidentally but if someone else did it I invite him/her to explain his/her reasons for doing so. The question is undeleted now

What do you see in the links?, so please delete the links. You can include the images here.

@mariosv LOL I use adblock so I’d not seen the surrounding images. I will never use that site again, apologies.
Corrected, the images are embedded now


You are right, I know of no option to print several print ranges on the same sheet of paper, sorry.


  • FilePrintPage Layout tab▸Pages per sheet: 2 (if you have 2 print ranges) (this is only a workaround, not a solution because of the page number).
  • If it is possible, hide rows/cols separating the cell ranges to be printed so as to make only one print range.
  • Create a “print sheet” or a printing spreadsheet include areas to be printed. This can be facilitated by DataDefine Ranges on cell ranges to be printed. In the printing sheet SheetLink to External Data to insert them (can be the same spreadsheet).


Thanks, Pierre, you seem to be well aware of this problem. I hope a solution becomes available in the future.
I’ve a question about the third workaround. You say the ranges can be from the same spreadsheet, right? I define and name a print range in Sheet1 called “range1”, but when I go to Sheet2 and select Insert > Link to external data the range doesn’t show there. If I load the very same file, it still doesn’t show. Am I doing this the right way? What am I missing?

@printRick - Available Tables/Ranges are displayed after having selected and confirmed the Url of External Data Source (top of the dialog).

Well, that’s what I did. I selected the very same spreadsheet file but they didn’t show (they show in the Manage Names window though). I’ve another question: how do you get that cool red monospace with arrows formatting? Is it available from a toolbar while posting answers or are there some hidden codes to use it? I accidentally discovered how to use bold text in this question, but apart from that I don’t know how to format text at all. I don’t even know how to put line breaks in questions.

Sometimes you need to use Enter key in the url zone to validate. That is what I wanted to say with “after having select and confirmed” (my english is poor, very sorry…).

Another hypothesis could be that you must save the spreadsheet after setting names.


  • Red monospace: select the text and click in the toolbar on 101010 (arrows are not added, I copy and paste from outside).
  • Line break: you need to do two to generate one.

Your English looks pretty normal to me, your second hypothesis is the actual reason. I reloaded and the ranges appeared.
Thanks for the formatting tips.

We use Freeze Rows and Columns so we can scroll the sheet independently of the titles of the rows or columns, but still keep them aligned. It doesn’t make sense to me that we can’t directly print the custom scrolling of rows or columns without resorting to Printscreen.

There is apparently a way to remove the page breaks from print ranges, but I can’t get it to work for me.

Alternatively, you could copy and paste what you need to a new sheet, and print that. Clumsy.