How to Print to a wide envelope

Using LO Version, Build ID: 1:6.07-0ubuntu0.18.04.10 on Kubuntu 18.04
I am trying to print to a wide, 22cm x 11cm envelope, which must be inserted into my printer in portrait orientation.

I have used the Envelope facility in Writer: Insert → Envelope, entered the addressee, set the format, and set the Printer → Envelope Orientation to the fifth option, Portrait Centred.
So far, it looks great:

My Envelope settings are thus:

I Setup the printer thus:
image description

I then Print Preview and get this (OK so far):
image description

Finally I Print and get this:
As you can see, the paper is oriented correctly but I need to have the text-formatting rotated 90 degrees, so it prints vertical text on the envelope. When I print this, it looks exactly like the preview shown.

I repeat Insert → Envelope, In the Printer tab I change the Printer → Setup → Properties → Orientation to Landscape.
The Print dialog shows the exact same preview, and it prints exactly the same.

How do I fix this?

I understand from several comments/queries that this was not a problem in previous versions but became one in V5.4 and V6. What happened?

I have a similar problem, printing to a 245mm wide x 149 mm high envelope, but from Libre Office 7.0.4 to a Brother MFC-8850DN on macOS 10.13.6 High Sierra. LO prints the address parallel to the short ends of the envelope, which is 90° anticlockwise rotated from the correct orientation. I have the envelope orientation set to “vertical centred”, as in the above screen shot. However, on macOS with this printer, when I press the “Setup” button in the Envelope… Printer tab, there is no Options button to let me tell the printer the page orientation.

I suspect all answers to questions about printing envelopes will differ according to computer OS (and thus printer driver conventions), to printer (and thus paper size capabilities and printer driver implementations), to envelope size (some sizes having bugs in LO), and LO version.

I’d say you have conflicting definitions; in LibreOffice you have already defined that you want to print “landscape” on the envelope = LO prepares the print job accordingly. Now, your printer driver receives this information, you have defined the envelope orientation (feed direction), so far so good. I’m pretty sure that in the Setup for the printer you should select “Landscape” to be consistent with the info in the print-job - the printer is already considering the envelope as “landscape”.

May be confusing, but someone told me “never argue with low level programmers”…