How to protect the cells of only the first two rows of a Calc sheet

In a Calc sheet that I’ve been working on (there are 100 rows filled with data), I need to protect the cells of rows 1 and 2 only. The cells of all other rows need to be unprotected, and I need to add more rows as I go along working.

These are the steps I take:

  • Tools > Protect Sheet, under Allow all users of this sheet to: select the first two options
  • in the sheet, select the first two rows, Format > Cells …: Protected

The result is that rows 1 and 2 are protected (great!) plus also rows 101 to 1048576 (not so great). In other words, I cannot enter any data into the rows from 101 onward (Format > Cells is greyed out). What am I doing wrong?

By default, all cells are protected.
Therefore, we do this (using the example of a new document).

  1. Menu / Styles / Manage Styles. Click with the right mouse button on the Default style, then Edit Style, Tab Cell Protection. Uncheck Protected. OK.

  2. Select the first 2 rows and protect them in the Format cells dialog: Check Protected.

1 Like

Ah, and when I then add Protect Sheet, cells in rows 1 and 2 only are protected.

But with sheet protection, the background colours of columns (that I’d defined in the style) default to white. So if I see correctly we need to choose between having either protected cells or background colours, right?

Could you upload your example file?

Here it is:

protected-cells.ods (9.2 KB)

If you click on the sheet tab and unprotect it, the background colours reoccur.

1 Like

I think this is a bug that should be reported.

This is wrong.
Simply exit View → Value Highlighting (Ctrl+F8)

Value Highlighting


True. So we cannot have all three at the same time – protected cells, background colours, and value highlighting.