How to remove extension when remove gives error (writer2xhtml)

I had the extension writer2xhtml installed. It worked fine until quite recently, when it suddenly stopped, and its toolbar greyed out. I’d like to remove and reinstall it.

Trying to search for updates to the extension crashes Write.

Trying to remove the extension gives the error:
(com.sun.star.lang.IllegalArgumentException) { { { Message = “There is no such extension deployed: org.openoffice.legacy.writer2xhtml.oxt”, Context = (com.sun.star.uno.XInterface) @2311a117c70 } }, ArgumentPosition = (short) -1 }

Trying to install a new version anyway, gives the dialog:
You are about to install version 1.6.1 of the extension ‘Writer2xhtml export filters’.
The older version 0, named ‘writer2xhtml.oxt’, is already installed.
Click ‘OK’ to replace the installed extension.
Click ‘Cancel’ to stop the installation.

and then the error (on pressing OK):
(com.sun.star.lang.IllegalArgumentException) { { { Message = “Cannot detect media-type: file:///C:/Users/Ben/AppData/Roaming/LibreOffice/4/user/uno_packages/cache/uno_packages/lu14568bwevoz.tmp_/writer2xhtml.oxt”, Context = (com.sun.star.uno.XInterface) @2312480ce40 } }, ArgumentPosition = (short) -1 }

Starting in safe mode (last working version) starts without the old extension - but still no way to uninstall it.

How can I uninstall this old version of the extension?

Reset the user profile or at least the extensions section.

Thanks. Deleting the user profile solved this.

https://wiki.documentfoundation.org/UserProfile#Default_locations

Deleting the user profile solved this

yes - but too much of a good thing. It would have sufficient to … see my answer.

Well, if you talk about sufficient, then navigate to the extensions directory, find the directory where the extension in question is installed (something like /lu7455bk9df) and delete it with its counterpart .tmp file.

As it happens, I didn’t see Opaque’s answer, so gabix’ was helpful.I reinstalled the extension, and it eventually malfunctioned again, so I’ve now been able to test all three answers - now deleting the uno_packages[…] directory, and tmp\extensions[…] directory. It seems to require some persistence to get to reinstallation again.

Hello,

delete all content (incl. sub-directories) of directory C:/Users/Ben/AppData/Roaming/LibreOffice/4/user/uno_packages/cache/

Hope that helps.