How to remove language packs and add one

Linux Mint 6.0: LO write: Tools, Options, Language Settings, Languages… User Interface shows “Default - English (USA)” only. That’s OK.
Default Languages for Documents shows “Default - Dutch (Netherlands)” and allows selecting from a long list. I’d like to delete most of the options, keep a few (German, French, English, Dutch). HOW?
Trying to check Spelling “Text Language” shows “None” and though there is a list to select a language from English (Australia) to Spanish (Venezuela) - Dutch (Netherlands) is missing - selecting any language fails. “None” remains. Automatic Spell Checking is ‘on’ but does not function.
Summary: I’d like to remove non-required languages and be able to select one (from a few) for Spell Checking.

The default language for document menu shows all possible languages. This does not mean they are installed.

Only those for which there is a small icon at left of name are effectively present on your machine. The small icon varies with the theme (both in LO and in your desktop). On mmy srteamlined machine, it is an uppercase A.

Removing on adding a language pack is done with your package manager. Filter them with “libreoffice” and look for “langpack” subcategory (and eventual “help”).

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Two questions remain:

  1. After manipulating the Package Manager I have now installed only hunspell-en-us, hyphen-en-us and hyphen-nl. Note that hunspell-nl is missing. How (and where) do I get it?

  2. In LO-Writer, Tools, Options, Language Settings, Languages I have under Language Of’ - User interface: ‘Default - English (USA)’, Locale setting: ‘Dutch (Netherlands)’ and that’s fine. Under ‘Default Languages for Documents’ Western: ‘English (USA)’. Here I can select six other languages, six variations of French.

Those are the only seven that have the small icon mentioned above. Dutch is NOT in the long list from Afrikaans (Namibia) all the way to Zulu. It follows that this (long) list does not ‘live’ in the Package Manager. I’d like to know

(a) how to get Dutch in this list (with the little icon)

and (b) how to delete the six variations of French.

Not familiar with Mint package manager. In Fedora, packages are named libreoffice-langpack-xx (xx=fr, nl, de, whatever) and contain whatever is needed to have consistent activation of language in LO. Dependencies take care of prerequisite packages.

Hunspell is necessary. If it does not install automatically, force it with the package manager. Next, I think the dictionary is also a prerequisite. If it is not present, it won’t work and the small icon is not added.

To remove a language, use your package manager. Is yours a GUI or TUI (command line) one? I prefer GUI ones because they show information in a more synthetic way.

After playing around a little more the “problem” is solved. In Linux Mint (19.3) I first installed Dutch and English (USA) and removed all other languages. English (USA) reported ‘packages missing’, corrected that by clicking on that message. Following that I found that Dutch was now available in the LibreOffice list of languages to select 'Default Language for Documents" (under Options, Language Settings).

In the process of trying to get this working I found that Package Manager does not show hunspell-nl when searching ‘libreoffice’ packages. Trying to force installation with ‘sudo apt-get install hunspell-nl’ results in ‘hunspell-nl is already the newest version (2:2.10-6)’. Strange. Searching ‘hunspell’ in Package Manager shows it as installed.

hunspell is independent of LO. If you are filtering packages on “libreoffice”, hunspell won’t appear (as expected)… But you may have hunspell installed, since it is in the dependency list for LO, but this is only the “engine”. You need to install the payload, i.e. the specific operational parameters for en, nl, de, … This can’t be put in the dependencies lest all languages become installed.

OK, I understand that Linux Mint languages and LO languages are two different things. Going to LO Tools, Language Settings, Languages there is a long list under ‘Default Languages for Documents’ from Afrikaans (Namibia) to Zulu. Many of them have the icon mentioned earlier (a sort of ‘tick-mark’ with ABC): Dutch and some English, some French, a complete list of all Spanish, etc. The Default (in the list) is Dutch (Netherlands). Fine. Earlier I had the problem that Dutch was not in the list, now it is.
When I open an LO document to check spelling (Tools, Spelling), ‘Text Language’ shows the default: Dutch (Netherlands). If I decide to select another language (just for one document) I get to see the whole list of ‘iconed’ languages. That makes sense, those are the ones I can select from. But seeing the long list (40 languages) is unpleasant. I’d like to shorten that list to two or four. How?

Unfortunately, you can’t.

If you’re primarily working in two languages, an ugly workaround is to play with your locale (Dutch) and a different default setting for documents (e.g. English). These two primary languages will appear in the menu which pops up when you click on the language in the bottom status bar.

When creating your document, click there (in the status bar) to select one of these two languages.

Since the choice is betwen the locale and the default language only, you can’t have more than two preset languages. But that’s better than nothing.

Thanks very much!! This solves the immediate problem. By the way, I believe this problem surfaced after switching to Mint 19.3. I cannot remember having the same problem earlier, when I used Mint 18.1.
Finally, two comments:

(1) it’s unclear (to me) what sets the ‘icons’ on the the long list of languages (from Afrikaans to Zulu). That seems to be rather random (cannot believe it is) because I see a FEW ‘French’ tagged with icons and ALL ‘Spanish’. Is there anywhere some document that tells me why?

(2) would be nice if LO could be improved to avoid the problem above. For instance by allowing the user to select a few languages available for spelling checks. Thunderbird could be seen as an example: the spelling check allows selection of languages made available.

(1) It depends on what is in the language packs or rather how they were made. All packs have a base payload and may provide national variants. The list doesn’t show the base language (which is supposed to be implicit, I assume) but flags fr_BE, fr_CA, fr_FR, fr_LU, fr_MC and fr_CH, not fr_CI, … Probably, nobody ever checked if Ivory Coast French was identical to an existing national variant et provided the indicated variant. If you live in Ivory Coast, you’d probably choose fr_FR while in the Democratic republic of Congo you’d choose fr_BE, as nearest possible equivalents.

I haven’t loaded the Spanish pack to see the enabled national variants. If all are flagged, either the pack makers have decided that the base dictionary and spell-checker is a kind of one-size-fits-all, which is linguistically not accurate, or LO is so widely used in South America that myriads of contributors have participated in the task of upgrading the pack.

I believe the truth is in-between.

(2) LO is language agnostic until you load some language pack. But the presence of a language pack should not prevent you from using exotic language such as Klingon or Cuneiform for which there is no dictionary or spelling checker AFAIK.

It is interesting to be able to flag entire paragraphs or words as belonging to any language. Consequently, it would not be wise to restrict the language menu to only installed languages. Yes, when you work routinely in a reduced set of languages, there is a real performance boost with a small menu.

Personally, I set the document language with Tools>Options and I have a handful of styles duplicating Text Body and common others which are flagged with the other language(s). Thus I only need to apply the styles without going through the long menu.

There is also language [None], not to be neglected, for all the “non-language” words like computer names (variables, functions, classes …), math or trade marks to push them out of spellcheck.